Support » Plugin: Block Pattern Builder » Missing patterns

  • While I can still create patterns just fine with Block Pattern Builder, I can no longer add them to pages, because they’re no longer listed the Patterns tab of the block inserter. All that’s listed there now is the default demo patterns from the Gutenberg plugin itself. Is this from an API change in Gutenberg 8.4.0?

Viewing 11 replies - 1 through 11 (of 11 total)
  • bryanhiggs

    (@bryanhiggs)

    I’m running WordPress version 5.4.2, with the Gutenberg plugin Version 8.5.1.

    I created a block pattern using your Block Patterns interface, and it’s listed in the Block Patterns > Patterns, but it doesn’t show up in the Patterns list on my page that uses the Block Editor.

    Did I miss something?

    Did something change, to cause this plugin to no longer work?

    Thanks in advance…

    +1
    WordPress 5.4.2
    Block Pattern Builder plugin 1.0.0
    Gutenberg plugin 8.5.1

    Patterns do not appear in the Gutenberg editor menus. If I downgrade Gutenberg plugin to version 8.3.0, it does work but there is a deprecation warning:

    register_pattern is deprecated since version Gutenberg 8.1.0! Use register_block_pattern() instead.

    This is already fixed in for the next release (https://github.com/justintadlock/block-pattern-builder/blob/master/src/functions-patterns.php), when might that be released?

    Thanks for the great plugin!

    +1 && +1 Thank You!

    This is fixed in the version found on GitHub:
    https://github.com/justintadlock/block-pattern-builder

    Checkout block-pattern-builder/src/functions-patterns.php and you’ll see that there is some conditionally logic for newer versions of Gutenberg. Either replace just that file or the whole plugin from GitHub and you’ll be good to go.

    For those of us who like to get our plugins from the official wordpress.org source, when will this plugin be available from there?

    Tried the plugin in 5.5 Beta. Allows creating the pattern, but like above, it does not show in the list of available patterns when creating content and adding a block.

    Figured out the issue in the 5.5 beta, the function to register a pattern is now register_block_pattern()

    Would be nice to be able to categorize the patterns

    Plugin Author Justin Tadlock

    (@greenshady)

    The plugin is updated on .ORG now, so this should be fixed.

    bryanhiggs

    (@bryanhiggs)

    Thank you!

    I am using version 1.1.0 of this plugin and love it so far. However, I am having this same issue or something similar. I can create patterns in the Block Pattern menu area but the post editor only shows the last created pattern in the patterns menu. In other words, I’ve created two patterns but only the last one created shows up in the patterns section of the post editor block selector.

    I had a similar problem, and in the pattern menu I could see only 10 patterns.
    Even, when I searched for the specific pattern, if it was not in that list of 10 patterns it was not shown.

    Problem found:

    I have noticed that number of patterns shown is the same as the number set in the “Blog pages show at most” in the Settings -> Reading.

    @jimvail I guess you see only one pattern because you have set this to one (1).

    Where is the problem:

    In the plugin’s file: “block-pattern-builder/src/functions-paterns.php
    Line number’s: 52-55

    WP_Query is created in order to list all patterns:

    
    	$patterns = new WP_Query( [
    		'post_type'    => 'bpb_pattern',
    		'number_posts' => -1
    	] );
    

    Used attribute ‘number_posts‘ is wrong and does not exist in the list of attributes that WP_Query can have.

    So, in order to list all patterns, we can use:
    ( Source: https://developer.wordpress.org/reference/classes/wp_query/#pagination-parameters )

    
       'posts_per_page' => -1
    

    or, maybe better:

    
       'nopaging' => true
    

    So, we have to change the above code with the following one:

    
    	$patterns = new WP_Query( [
    		'post_type' => 'bpb_pattern',
    		'nopaging'  => true
    	] );
    

    And, the problem is solved. (At least, it works for me. 🙂 )

    @greenshady If you find that this is OK, would you like to update the plugin with this fix, please?

    Thanks,
    Tony M.

    • This reply was modified 2 months, 1 week ago by Tony M..
    • This reply was modified 2 months, 1 week ago by Tony M..
Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.