WordPress.org

Support

Support » How-To and Troubleshooting » Memory problems :(

Memory problems :(

  • payneardo
    Member

    @payneardo

    Hi, hope you can help as this is now doing my head in.

    I am trying to upload an image which is about 190K in size and getting an error Fatal error: Allowed memory size of 31457280 bytes exhausted (tried to allocate 12032 bytes)

    I have edited the php file, edited my wp_config file, edited the media.php file and wherever else it says 🙁 if I put it in my .htacces file it crashes my site.

    I have phoned 1 and 1 my hosting provider and they have said I have to put a php.ini in every single folder on my website is this right??

    Please help

    Cheers

    Dave

Viewing 4 replies - 1 through 4 (of 4 total)
  • esmi
    Forum Moderator

    @esmi

    It varies from host to host. If that’s what 1&1 say, then it must be so on their servers.

    ce_kevinw
    Member

    @ce_kevinw

    Dave,

    The php.ini file is not recursive, however if you add this to your .htaccess file:

    suPHP_ConfigPath /home/username/public_html (the path to your root directory)

    That will apply your local php.ini settings to all folders (assuming 1and1 has suPHP on their servers).

    Which php.ini settings are you modifying and what are you modifying it to?

    Christophtopherson
    Member

    @christophtopherson

    I dont mean to hostbash, but 1and1 sucks. I use certifiedhosting and they seem to me to have their servers configured pretty well, i see problems like yours and even more ridiculous ones all the time and im happy to say I never have those problems. id switch to another host while you still can

    payneardo
    Member

    @payneardo

    Cheers for all the message, if I change it in .htaccess file my website stops working but I think I have now solved the problem.

    It seemed to be if the photo was above 1920×1024 resolution it wouldn’t upload no matter what physical size of the photo was. Its a bit steange but when I used gimp to size the photo down, it uploaded no problems 🙂

    Thanks again for all the replies 🙂

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Memory problems :(’ is closed to new replies.