Support » Fixing WordPress » Masterplan Theme problem with Categories

  • I have this theme installed, and i love it for what I am doing at however my categories don’t seem to be working with the theme I get a line 32 error
    <?php wp_list_categories(

    and this is it in context

    <ul class="archives">
    <?php wp_list_categories('title_li=&sort_column=name&show_count=
    1&show_last_updated=1&use_desc_for_title=1&exclude=' .$catid. '') ?>

    It’s fresh out the box .. so i don’t know why it doesn’t work.

    For the record .. if i delete all those lines then i still get the same error .. so i am guessing the error is because of something else.

    I have posted in their support forums but no one seems to know.

    My default theme works fine but you can see with this theme if you go to a certain topic (or category) you get the error.

    does anyone have any ideas ?

Viewing 6 replies - 1 through 6 (of 6 total)
  • Any chance there is a line above it with the } ? In any case, hard to troubleshoot coding errors without a look see at the source. So if you can go here:

    And paste the source of the theme’s archive.php up there (reply back with the url), we should be able to track down the cause.

    there is the source code for archives.php

    i have been messing around but no luck so far.

    Actually, you want the source for archive.php, not archives.php. The first affects category queries, while the latter — the one you’ve uploaded — is a Page template.

    Perhaps this has been part of the problem?

    Ok so thats my archive.php page .. i am going to play with it now.

    Glancing at it, it appears you’re missing a starting if statement block in the code, since line 32 is an elseif.

    Ok, pulled up the original template and on line 16 is:

    <?php if (is_category()) { ?>

    That is the only actual difference between the two versions of archive.php (that is, yours is missing it). And it’s definitely the cause of the error, because without the starting if the elseif blocks become invalid code.

    That fixed it … thank you so much !

    I have no idea yet why my code was missing it .. or if anyone elses is missing it .. as i never altered the code of the theme !

    anyway s.. all ended up good now .. thanks !

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Masterplan Theme problem with Categories’ is closed to new replies.