Support » Plugin: Gravity Forms Infusionsoft Feed » Mapping Fields

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author Systasis Computer Systems

    (@systasiscomputersystems)

    Ho did you get the map fields section to look like that? That’s not correct, the standard fields (Company, Email, First Name, Last Name) are missing. I’ll try reinstalling the current version to reproduce.

    update: What version are you using? You should be using 2.2.2

    • This reply was modified 2 years, 8 months ago by Systasis Computer Systems. Reason: Add version id question. Can't reproduce yet
    Thread Starter ryan360

    (@ryan360)

    I am using 2.2.2, Infusionsoft SDK 1.0.12, and GravityForms 2.3.2

    • This reply was modified 2 years, 8 months ago by ryan360.
    Plugin Author Systasis Computer Systems

    (@systasiscomputersystems)

    The version numbers are up-to-date.
    Still unable to reproduce this issue.
    Here are a few suggestions and a request:

    1. Delete the plugin from wp-content/plugins/systasis-gf-infusionsoft-feed and reinstall
    2. Clear the plugin cache on the Settings page.

    Please export the gravity form that you’re using, and send it to jeff@systasis.co

    Plugin Author Systasis Computer Systems

    (@systasiscomputersystems)

    I can reproduce this when the Infusionsoft field list is empty.

    That narrows it down to either the connection or the cache.

    I think it’s the connection. Please verify the API key and app name in the Novak SDK

    Plugin Author Systasis Computer Systems

    (@systasiscomputersystems)

    I’m going to close this issue, and update the feed add-on to gracefully handle connection issues.

    Thread Starter ryan360

    (@ryan360)

    I think it was the connection but I’m not sure how to tell if it’s working. I generated a new API Key here: https://keys.developer.infusionsoft.com/apps/myapps and updated the API key in the Novak settings but I don’t see any way of clearing the cache. When I go to the settings on the form the page takes a long time to load and still looks the same as it did in the previous screenshot.

    • This reply was modified 2 years, 8 months ago by ryan360.
    Plugin Author Systasis Computer Systems

    (@systasiscomputersystems)

    It looks like I didn’t include clearing the cache in the readme.
    From the admin page:
    Forms > Settings > Systasis Gravity Forms Infusionsoft Feed Add-On > Clear Custom Fields Cache

    Unfortunately, I don’t think there’s anything in the cache to clear.

    Please contact me at jeff@systasis.co so we can communicate offline. I will want to see your Infusionsoft app id and key. You can also invite jeff@systasis.co as a partner to your app and I can check these values.

    Plugin Author Systasis Computer Systems

    (@systasiscomputersystems)

    If you’re interested, I’ve prepared an early release version of the plugin available here

    This version implements Infusionsoft connection failure reporting.

    You’ll have to uninstall the current version and then upload this version.

    This version displays a notice if the plugin cannot connect to Infusionsoft. This usually will be caused by misconfiguring the app name or API key. This error will also be reported if your WordPress server cannot connect to the Infusionsoft server. There is currently no provision in the plugin to debug that kind of connection issue.

    Thread Starter ryan360

    (@ryan360)

    After updating to the beta version of the plugin and clearing the cache, it now says “No Infusionsoft fields found!” when I go to edit the Feed.

    Thread Starter ryan360

    (@ryan360)

    Am I using the correct Infusionsoft SDK plugin? https://wordpress.org/plugins/infusionsoft-sdk/

    Plugin Author Systasis Computer Systems

    (@systasiscomputersystems)

    Yes, you are using the correct SDK. Yes, I know it hasn’t been updated for several years. The Infusionsoft API changes are not relevant to the that version of the plugin.

    “No Infusionsoft fields found”. Very odd. If you’ve installed the updated version, cleared the cache and and aren’t receiving a “connection failed” message, then there is something else wrong. I appreciate your help unconvering the unreported connection issue, and the documentation issue regarding clearing the cache. I want to work with you to resolve this issue. Nevertheless, almost 2 weeks have passed since this our last communication.
    Please contact me offline if you want to continue.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Mapping Fields’ is closed to new replies.