WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Lot of Errors when WP_DEBUG is true

[Resolved] Lot of Errors when WP_DEBUG is true

  • alpha1beta
    Participant

    @alpha1beta

    Just FYI, when you turn on WP_DEBUG, there are a bunch of errors in the header area.

    Notice: Use of undefined constant SENDGRID_CATEGORY - assumed 'SENDGRID_CATEGORY' in /wordpress/wp-content/plugins/sendgrid-email-delivery-simplified/wpsendgrid.php on line 18

    Notice: Use of undefined constant SENDGRID_PLUGIN_SETTINGS - assumed 'SENDGRID_PLUGIN_SETTINGS' in/wordpress/wp-content/plugins/sendgrid-email-delivery-simplified/wpsendgrid.php on line 19

    Notice: Use of undefined constant SENDGRID_PLUGIN_PAGE - assumed 'SENDGRID_PLUGIN_PAGE' in wordpress/wp-content/plugins/sendgrid-email-delivery-simplified/wpsendgrid.php on line 20

    Strict Standards: call_user_func_array() expects parameter 1 to be a valid callback, non-static method wpSendGridSettings::sendgridPluginMenu() should not be called statically in wordpress/wp-includes/plugin.php on line 429

    http://wordpress.org/plugins/sendgrid-email-delivery-simplified/

Viewing 2 replies - 1 through 2 (of 2 total)
  • alpha1beta
    Participant

    @alpha1beta

    Actually while talking a look, you have 3 DEFINE statements, where the term being defined is not in quotes. just a single quote around them will fix almost all those errors.

    Plugin Author SendGrid INC
    Participant

    @team-rs

    This issue was fixed. You can update your plugin. Thanks for reporting this!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Resolved] Lot of Errors when WP_DEBUG is true’ is closed to new replies.