WordPress.org

Support

Support » Plugins and Hacks » Twitget » [Resolved] Loses all settings

[Resolved] Loses all settings

  • Testing this plugin on a fresh WordPress install:
    – everything untouched, default theme
    – WP_DEBUG turned on in wp-config.php

    PHP Notices after saving the settings:

    Notice: Undefined index: twitget_show_powered in /xxx/twitget.php on line 365
    Notice: Undefined index: twitget_use_custom in /xxx/twitget.php on line 370
    Notice: Undefined index: twitget_before_tweets_html in /xxx/twitget.php on line 378
    Notice: Undefined index: twitget_tweet_middle_html in /xxx/twitget.php on line 379
    Notice: Undefined index: twitget_tweet_end_html in /xxx/twitget.php on line 380
    Notice: Undefined index: twitget_after_tweets_html in /xxx/twitget.php on line 381
    Notice: Undefined index: twitget_after_image_html in /xxx/twitget.php on line 382
    Notice: Undefined index: twitget_before_profile_html in /xxx/twitget.php on line 383

    Notice: Undefined index: show_relative_time in /xxx/twitget.php on line 545

    Notice: Undefined index: title in /xxx/twitget.php on line 640 (on the Widgets admin page)

    PHP notices are usually nothing to worry about, and the widget works at first. But when I then return to the settings page, all checkboxes are ticked, and ALL fields are populated with the same random, single character. Usually a or A, sometimes an unsupported character.

    And this breaks the widget, of course:
    Fatal error: Cannot use string offset as an array in /var/sites/t/twitget.antfarm.at/public_html/wp-content/plugins/twitget/twitget.php on line 208

    I’ve deleted and re-installed the plugin a few times, but the behaviour remains the same: it happens every time, after I add the widget to a sidebar.

    As bugs go, this is huge – I’ve never seen a plugin drop its settings like this. I hope you can find the problem.

    http://wordpress.org/extend/plugins/twitget/

Viewing 15 replies - 1 through 15 (of 16 total)
  • Plugin Author Boštjan Cigan

    @zerocool51

    Sorry about that. Could you download the latest version again and try again?

    I’ve got the latest version (2.0?). Deleted and downloaded it several times, about 1 hour ago.

    Plugin Author Boštjan Cigan

    @zerocool51

    Try again, I’ve just commited some minor modifications.

    Tell me if the notices and the error still appear.

    No, same thing (I’m getting fewer PHP notices, but I don’t know if that is because I’ve changed fewer settings).

    But the version number is still 2.0, so apparently I’m not getting the latest version.

    Plugin Author Boštjan Cigan

    @zerocool51

    You’re installing from scratch, and the A’s appear in all your fields when you add the widget?

    Yes – and the WordPress install is only a few hours old as well. No other plugins, nothing.

    I checked via ftp if the plugin files are deleted, and re-installed. Same problem.

    Plugin Author Boštjan Cigan

    @zerocool51

    Please try 2.0.1.

    I’ve installed a fresh version, added a widget and it worked.

    I’ve also updated from a previous version and it also worked.

    Same issue with 2.0.1.

    Plugin Author Boštjan Cigan

    @zerocool51

    Could you tell me the exact steps you went through before the settings got filled with random characters? And your twitter account username?

    Account is @antgriculture (Ant Farm)
    Test site is http://twitget.antfarm.at

    Exact steps:

    1. Install the plugin
    2. Add details: username (without the @), consumer key, consumer secret, access token access token secret)
    3. Navigate to another page in admin, go back to Twitget settings: looks alright, settings still there
    4. Add widget to sidebar, enter title (I tried different titles)
    5. Check website: widget works
    6. Go back (or reload) Twitget settings page: settings dropped, all fields show single random character: A, a, <, or unsupported character

    Plugin Author Boštjan Cigan

    @zerocool51

    I need just this little bit:

    – PHP version
    – WordPress version
    – WordPress theme you are using

    Cheers.

    PHP 5.3.10
    WordPress 3.5.1
    Twenty Twelve theme

    Plugin Author Boštjan Cigan

    @zerocool51

    Just letting you know I’m trying to reproduce this one so that I could fix it.

    Cheers!

    Plugin Author Boštjan Cigan

    @zerocool51

    Rootside, I haven’t been able to reproduce this issue, but I’ve made some changes.

    Please try the development version and report back – http://downloads.wordpress.org/plugin/twitget.zip

    If it still doesn’t work, please send me your keys (consumer, secret etc.) on email – you can get my contact info here – http://bostjan.gets-it.net

    Cheers.

    Thanks, but no thanks.

    At the moment (Twitget 2.1), I can’t even log into the test site without deleting Twitget. “PHP Warning: Cannot modify header information – headers already sent by (output started at /xxx/twitget.php:194) in /xxx/wp-includes/pluggable.php”

    Sorry, but it’s just too unreliable.

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘[Resolved] Loses all settings’ is closed to new replies.
Skip to toolbar