Support » Plugin: Link Library » Link Library on the localhost

  • Under the Vertrigo WAMP.
    Since installatio the 6 … version of the link Library, a blank page with such message is displayed:
    Not Found
    The requested URL /darz-bor.info/katalog-przyrodniczych-stron-www/ was not found on this server.

    Pressing the [Re-import liks] button makes the php displaying this:

    ( ! ) Warning: Invalid argument supplied for foreach() in C:\Users\user name\Documents\My Web Sites\darz-bor.info\wp-content\plugins\yet-another-stars-rating\freemius\includes\managers\class-fs-admin-menu-manager.php on line 513
    ( ! ) Warning: Cannot modify header information – headers already sent by (output started at C:\Users\user name\Documents\My Web Sites\darz-bor.info\wp-content\plugins\yet-another-stars-rating\freemius\includes\managers\class-fs-admin-menu-manager.php:513) in C:\Users\user name\Documents\My Web Sites\darz-bor.info\wp-admin\includes\misc.php on line 1124
    ( ! ) Warning: Cannot modify header information – headers already sent by (output started at C:\Users\user name\Documents\My Web Sites\darz-bor.info\wp-content\plugins\yet-another-stars-rating\freemius\includes\managers\class-fs-admin-menu-manager.php:513) in C:\Users\user name\Documents\My Web Sites\darz-bor.info\wp-includes\pluggable.php on line 1219

    Full tect of these messages is here:
    http://darz-bor.info/pliki/temp/localhost.htm

    It is worth to note, that paths beginning wit c:// are used instead of http://localhost/.

    Versions 5 … were working on localhost.

Viewing 4 replies - 16 through 19 (of 19 total)
  • – No errors when Link Library is deactivated. I was changing options in WP Security (localhost), AFS Analytics and Slimstat Analytics (internet).
    However the Link Library generates erros only in case of some options (Library Configurations: Categories etc.)

    – Yes, I did not have been running the most recent version of Link Library 5.9 before updating to 6.0, So I did what you adviced – removed 6, installed 5.9 and updated to 6. On the localhosturing re-import such error was displayed:
    ( ! ) Fatal error: Maximum execution time of 30 seconds exceeded in C:\Users\user name\Documents\My Web Sites\darz-bor.info\wp-includes\plugin.php on line 885

    On the localhost 17 links appeared (from above 560), one of them contains error:
    ( ! ) Warning: date() expects parameter 2 to be long, string given in C:\Users\user name\Documents\My Web Sites\darz-bor.info\wp-content\plugins\link-library\link-library-admin.php on line 5750

    In the internet (not localhost) such blank page was displayed:

    405 Not Allowed
    nginx/1.14.0

    and about 400 links were imported.

    Yet Another Star rating does not interfere during changing configuration of the Link Library on the localhost, but interferes in the internet.

    I reverted the internet Link Library database to previous one, imported manually (through css, Microsoft Access, .sql files), with 560 links.

    • This reply was modified 1 year, 4 months ago by  darekk2.
    • This reply was modified 1 year, 4 months ago by  darekk2.
    • This reply was modified 1 year, 4 months ago by  darekk2.
    Plugin Author Yannick Lefebvre

    (@jackdewey)

    So, can we consider this closed since you finally got your links imported?

    Yes, but only some of links, because import broke. But the basic reason of everything was starting from version earlier that 5.9.

    Plugin Author Yannick Lefebvre

    (@jackdewey)

    Right. I have just modified the importer to be able to update the tables if you come in from an older version. That will be in 6.0.46, available soon.

Viewing 4 replies - 16 through 19 (of 19 total)
  • The topic ‘Link Library on the localhost’ is closed to new replies.