WordPress.org

Support

Support » Plugins and Hacks » [Resolved] link-library fatal error – php5 issue?

[Resolved] link-library fatal error – php5 issue?

  • cubecolour
    Moderator

    @numeeja

    I am unable to activate the link-library plugin on a WP 2.7.1 site running on PHP5. I have it working perfectly on other sites with PHP4.

    Plugin could not be activated because it triggered a fatal error.

    Parse error: syntax error, unexpected ‘}’ in /home/sites/stheliervts.co.uk/public_html/wp-content/plugins/link-library/link-library.php on line 503

Viewing 3 replies - 1 through 3 (of 3 total)
  • Yannick Lefebvre
    Participant

    @jackdewey

    I’ve had one other user with a similar error on that line of code. However, she was running on a local server that she setup herself. Everything was fine on the production server that was hosted by a provider service. Is this server with PHP5 one that you configured yourself or a hosted service?

    Yannick

    cubecolour
    Moderator

    @numeeja

    Its on a commercial host, but I believe I have now found the cause of the issue.

    After changing <? in the first line to <?php it works perfectly on php5 (so far).

    Thanks for a great plugin

    Yannick Lefebvre
    Participant

    @jackdewey

    Thanks for letting me know what you changed. I added the php keyword to the first line of the plugin and tested that it did not seem to break anything on my personal site. The change is now in version 1.1.7.2.

    I also notified my other user who had this problem to try this new update.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Resolved] link-library fatal error – php5 issue?’ is closed to new replies.