Support » Plugins and Hacks » LDAP plugin fatal error in 2.2.1

  • Resolved alistairskye

    (@alistairskye)


    I’ve just upgraded from 2.0 to 2.2.1 and my LDAP plugin has stopped working:

    “Plugin could not be activated because it triggered a fatal error”

    The plugin overrides wp_login and wp_setcookie.

    Is there any way to find out why it won’t start?

Viewing 3 replies - 1 through 3 (of 3 total)
  • Found the problem. In the plugin, I had to surround the functions with:

    if ( !function_exists(‘wp_login’) ) :

    endif;

    and

    if ( !function_exists(‘wp_setcookie’) ) :

    endif;

    you don’t need these function_exists checks in 2.0 in your plugin but you certainly need them in 2.2.1

    Hey,
    Can someone provide me with a sample file with the fix? I’m a little new to PHP. Thanks

    After getting in touch in and getting “approval” from its author, I’m attempting to fork off and revive wpLDAP and would like the code to be peer reviewed by other developers before I release my version.

    Please see http://wordpress.org/support/topic/129814

    Thanks for any help I can get. 🙂

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘LDAP plugin fatal error in 2.2.1’ is closed to new replies.