WordPress.org

Support

Support » Plugins and Hacks » JM Twitter Cards » [Resolved] Latest version not working on PHP 5.4.26

[Resolved] Latest version not working on PHP 5.4.26

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Author tweetpressfr

    @jmlapam

    Hi it should be fixed in 5.1.7 do you have the latest version?

    Yes, already downloaded 5 minutes ago from WordPress repository…

    Plugin Author tweetpressfr

    @jmlapam

    Super weird. Can’t reproduce the bug. Will do some tests, thanks for reporting.

    Ok, thanks for your help. If you need any other info about my installation, please let me know. I will be waiting for your news.

    By the way, Is there any way of download any previous version, in order to try if they work?

    Plugin Author tweetpressfr

    @jmlapam

    What I need to know is whether it’s coming from the plugin or something else. Can you activate debug on your installation?

    This is the message when debug mode activated:

    Fatal error: Call to undefined function wp_enqueue_media() in /mysite/wp-content/plugins/jm-twitter-cards/inc/admin/meta-box/init.php on line 266

    Any idea?

    Plugin Author tweetpressfr

    @jmlapam

    ok thanks, what is your wordpress version?

    WordPress version 3.4.1

    Plugin Author tweetpressfr

    @jmlapam

    This is my fault, I forgot to update wordpress version minimum required, in fact wp_enqueue_media() has been added in the core since 3.5.0 but even considering this can you update your installation?

    Ok, understood… But updating my installation will mean a lot of time testing with other plugins, versions, custom code, etc. I have to be very sure of what I’m doing!

    I do have the idea of updating my site, but not at this time.

    Is there any way of nulling that call “wp_enqueue_media()”, or it si totally necessary?

    If it is, is it possible to download a previous version of the pluging, working with wordpress 3.4.1?

    Plugin Author tweetpressfr

    @jmlapam

    what I can do is making the use of this function conditional to its existence, you won’t be able to select image for meta image through upload button but it won’t break admin.

    To be included in 5.1.8

    Thanks for your help!

    And when is this new version 5.1.8 going to be launched?

    5 stars for your plugin if it is within today 🙂

    Plugin Author tweetpressfr

    @jmlapam

    It’s for today anyway ^^ this evening.

    Thaks so much! You will get the 5 stars then… 🙂

    Will you send me a short reply as soon as it is solved?

    Thanks again JM, you rock!

    Plugin Author tweetpressfr

    @jmlapam

    Fixed now eventually ^^

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘[Resolved] Latest version not working on PHP 5.4.26’ is closed to new replies.
Skip to toolbar