Support » Plugin: Leaky Paywall for WordPress » Latest update shows PHP warning

  • The latest update to 4.13.2 seems to now expose a Leaky Paywall error about “strip tags”. This error is displayed normally where the excerpted text would display, just above the nag message.

    It reads as follows: “Warning: strip_tags() expects at most 2 parameters, 3 given in /homepages/16/d210685788/htdocs/wp-content/plugins/leaky-paywall/include/class-restrictions.php on line 510.”

    A second warning reads as follows:

    “Warning: substr() expects at least 2 parameters, 1 given in …” the same class-restrictions.php file on line 510.

    We had to roll back to the earlier version of Leaky Paywall to resolve this issue.

    Are you working on a fix for this?

    Right now, you will not be able to reproduce the issue on our site, since we rolled back to 4.13.1. If needed, we can update the plugin so you can take a look, in order to see what’s going on, but we’ll have to do it after hours when site traffic is lower.

    • This topic was modified 2 months, 3 weeks ago by webifiedOne.
    • This topic was modified 2 months, 3 weeks ago by webifiedOne.

    The page I need help with: [log in to see the link]

Viewing 1 replies (of 1 total)
Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.