Support » Plugin: Admin Bar Button » Latest Update Not Working

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author David Gard

    (@duck_boy)

    Hi steveraven,

    I’m sorry to hear that you have encountered a problem with version 4.0 of Admin Bar Button.

    To troubleshoot the issue, could I please ask that you try the following –

    • First, deactivate other plugins one-by-one to check for an incompatibility. If deactivating a specific plugin fixes Admin Bar Button, please let me know which plugin it was so that I can look in to why they are incompatible.
    • Switch to one of the default WordPress themes. As with the plugins, if this fixes Admin Bar Button, please let me know which theme you were using so that I can look in what is causing Admin Bar Button to fail.

    If neither of the above tips works, please let me know which theme you are using, and any plugins that you have active so that I can carry out some further investigation.

    Thanks,
    David Gard

    Plugin Author David Gard

    (@duck_boy)

    Hi again,

    I have something else I’d like you to try if the above tips did not help you track down an incompatibility.

    First, look at the source of the page and copy the Admin Bar Button settings from the header. I’d like to see if there is an error there, which would cause the button to fail. For your reference, they’ll look like this –

    <script type="text/javascript">
    	/**
    	 * Admin Bar Button display options
    	 */
    	var djg_admin_bar_button = {
    		button_position:		'top-left',
    		button_activate:		'both',
    		bar_auto_hide:			true,
    		bar_show_time:			5000,
    		animate:			true,
    		animate_button_duration:	333,
    		animate_bar_duration:		666,
    		animate_direction:		'left'
    	}
    </script>

    After that, please visit the Admin Bar Button settings page and click the **Restore Defaults** button. I appreciate that you may have customised your settings slightly, but this will tell us if something in the last update broke the plugin due to your settings.

    Thanks again,
    David Gard

    Plugin Author David Gard

    (@duck_boy)

    Hopefully I have found the bug that is causing you grief.

    I had accidentally misspelled z-index in one of the CSS files, meaning that on some themes with a fixed header, the header would float above the Admin Bar Button.

    I have committed a fix, and version 4.0.1 should be available to you now. If you could please update and let me know whether or not your problem has been fixed I would be most grateful.

    Thanks,
    David Gard

    steveraven

    (@steveraven)

    What wonderful support and service!

    Yes, it sort of… FELT like the bar was still there, even though it wasn’t visible.

    Rather than changing the if module {function = 'feels-like-its-there'} settings, a much better solution was to give the z-index a boot!

    All working fine now, and thanks for the update!

    Plugin Author David Gard

    (@duck_boy)

    That’s great news, thanks for posting back to let me know 🙂

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Latest Update Not Working’ is closed to new replies.