Support » Plugin: Mailgun for WordPress » Latest Update

  • Issue after the last update,

    It appears this line has started causing a 500 error on form submissions on a website where I updated this plugin.

    New:
    $phpmailer->SMTPSecure = (bool) $secure ? 'tls' : 'none';

    Old:
    $phpmailer->SMTPSecure = (bool) $secure ? 'ssl' : 'none';

    Could someone let me know if it’s possible to update to the latest version but keep the ssl auto type?

    Thanks,
    Sam.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Mailgun

    (@mailgun)

    Hi Sam,

    Please downgrade to 1.5.8.4 and I will try to get another fix out soon.

    Alternatively, you can remain on 1.5.8.5 and replace the 'tls' on that line with 'ssl' and it should work fine.

    In many cases though, TLS is preferred and should be usable on many systems — do you mind sharing some information about your hosting set up with me?

    Thanks!
    – Sean@MG

    • This reply was modified 10 months, 2 weeks ago by  Mailgun.

    PHP: 7.0.23 – Fast CGI served by Apache

    Don’t really have much in the way of other details, could you let me know if you need to know anything specifically and I can try and find that out for you.

    It’s running on a Plesk based server and the account I have access to doesn’t seem to give much in the way of server specific information.

    Plugin Author Mailgun

    (@mailgun)

    Hey Sam,

    I’ve added an option to the admin page that should let you set the SMTP security type. I have not released it yet, but could you please test out this beta and let me know if it fixes your issue?

    Thanks!
    – Sean@MG

    Testing this update today should know very soon if there are any issues. Thanks.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Latest Update’ is closed to new replies.