WordPress.org

Support

Support » Installation » Language change

Language change

  • I’m in the progress of installing WP, and so far so good, it works beutifully. But, when trying to change to Swedish, WP clings on to English, although I have been most obediant when installing ‘sv_SE’ in th new folder ‘languages’ and made appropiate modifications in wp-config.
    How come???

Viewing 15 replies - 1 through 15 (of 17 total)
  • Try making ‘sv_SE.mo’ into just ‘SE.mo’ ?

    In the wp-config???

    Yup – like the example gives.

    I have downloaded this file into a newly created folder ‘languages”.
    sv_SE.ISO-8859-1.mo
    According to your advice I then renamed this file to SE.mo.

    In the wp-confic.php I changed ‘lang’ to ‘sv’.

    Does it work?
    No 🙁

    define ('WPLANG', 'se');
    se.mo

    or
    define ('WPLANG', 'sv');
    sv.mo

    Now I have define (‘WPLANG’, ‘sv’); in wp-config
    and sv.mo in languages, and I have tried the se- as well, but i does not funktion.

    This getting strange…… back to the beginning.
    The languages file is in wp-includes/languages ?

    yes, in wp-includes/languages I have sv.mo

    and then I have
    define (‘WPLANG’, ‘sv’); in wp-config.php

    I have the very same error.
    Help someone?

    I have define ('WPLANG', 'nb_NO'); for Norwegian in my wp-config.php and my language file is called nb_NO.mo.

    For swedish: download the sv_SE.utf-8.mo and put it in wp-includes/languages. Then change the lang setting in the wp-config file to ‘sv_SE.utf-8’. That worked for me.

    I have the same problem for Norwegian nynorsk. nn_NO.mo put in /wp-includes/languages/, nn_NO in wp-config.php, but still, everything stays English.

    My blog attempt is at tur.frilyd.tk. Would anyone care to check whether I have done a terrible mistake?

    How could we check what have you done?
    If you want you can emal me with your ftp details and I can take a look.

    Sorry, I didn’t mean you to do the job for me… I just meant that those who know an .mo file from a .somethingelse file, could verify that my .mo file is usable, and thus eliminate that as the error source. But I am doing that right now, by entering the path for the .mo file, and I can’t find it.

    The file should be reachable here:

    http://tur.frilyd.tk/wp-includes/languages/nn_NO.mo

    but it isn’t!

    Hm. I’ll try installing WordPress in my root directory, and see what happens.

    By the way: My domain is hosted at 69.72.196.172, but entering that address in a browser will just tell that no domain is registered. But pinging tur.frilyd.tk, or just frilyd.tk, returns that exact address. There are some strange goings on here. Thank you so far, I’ll report back when I know more.

    Now that quite simplifies the problem: you didn’t upload it to the right place.

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘Language change’ is closed to new replies.
Skip to toolbar