Support » Plugin: Statify » Ladezeit-Problem?!

  • Resolved Madd1974

    (@madd1974)


    Hallo,
    erstmal Danke für euer sehr gutes Statistik-Plugin. Ich habe allerdings eine Frage. Ich habe es auf diversen Domains im Einsatz und es funktioniert soweit auch.

    Allerdings zeigen mir Ladezeiten-Tools wie Pingdom oder GTMetrics an, dass es eine große Wartezeit von meist bis zu einer Sekunde für dieses Plugin gibt. Da wird z.B. die URL https://www.abenteuer-brettspiele.de/?statify_referrer=&statify_target=%2F angezeigt, die diese Wartezeit verursacht.

    Woran kann das liegen und wie kann man das verhindern?

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Support Torsten Landsiedel

    (@zodiac1978)

    Ich gebe das nochmal weiter, aber schon mal zur Beruhigung: Der Request wird asynchron ausgeführt, daher ist die Ladezeit hier nicht wirklich relevant. Es stört nicht den Aufbau der Site.

    Gruß, Torsten

    Plugin Support Stefan Kalscheuer

    (@stklcode)

    Hi Madd,

    leider hatte ich bislang kein Glück, das Problem auf einer mir zugänglichen Seite nachzustellen.

    Hast du die Möglichkeit zu prüfen, wie hoch die Ladezeit für die Startseite ohne Caching Plugin ist? Wäre wichtig, um eine Vorstellung zu bekommen, in welcher Größenordnung wir uns auf dem System überhaupt bewegen.

    Statify kommt als Plugin mit S relativ weit hinten in der Liste, daher wäre es nicht auszuschließen, dass ein anderes Plugin die Ladezeit verursacht, welches vorher an der Reihe ist. Ohne o.g. Vergleichswert aber auch nur Spekulation.

    Gruß,
    Stefan

    Nachtrag:
    Ich habe mich gerade mal durch die Seite geklickt und einige, bislang offenbar ungecachte Seiten entdeckt, Ladezeit mitunter bis zu 2.5s (https://www.abenteuer-brettspiele.de/top-listen/top-10-brettspiele-2018-vorschau)
    Das spräche dafür, dass derartig lange Ladezeiten bei dir leider normal sind. Selbst aus dem Cache fallen zum Teil 200ms und mehr TTFB raus.

    Ungecachte Seiten sollte es eigentlich nicht geben, aber im Einzelfall kann das vorkommen. Bei den Tests mit Pingdom und Co. zeigt sich auch, dass die Ladezeit insgesamt mit ca. 500ms angegeben wird. Dennoch wird im Waterfall-Diagramm die Ladezeit für die genannten Statify-URL mit 1,25s angegeben.

    Ist gut zu wissen, dass es ansyncron lädt, aber hätte mich schon interessiert, was hier das Problem ist.

    Hier meine Pingdom-Analyse:
    https://tools.pingdom.com/?_ga=2.202744274.2126614194.1533109342-701080986.1533109342#!/eJTjbr/https://www.abenteuer-brettspiele.de/

    Plugin Support Stefan Kalscheuer

    (@stklcode)

    Ungecachte Seiten sollte es eigentlich nicht geben

    Beim Durchklicken habe ich schon eine Hand voll Seiten mit Erst-Ladezeiten >1s gefunden, die erst beim zweiten Aufruf <200ms lagen und den Cache-Kommentar in HTML enthielten. Normal, sofern nicht 100% der Seiten vorgeneriert werden und Caches nie ablaufen.

    Die Statify-Parameter in der URL brechen das Coaching auf (würde ja auch sonst nicht funktionieren), daher ist nur ein Vergleich mit der ungecachten Seite ohne Statify wirklich aussagekräftig.

    Grundsätzlich sollte man (wir) aber auch nochmal sehen, ob man noch früher reinkommt, um überflüssige Rechenzeiten anderer Plugins zu unterbinden (die 1-2s dreht der Server ja vermutlich nicht nur Däumchen). Insofern danke für den Anstoß.

    Danke für die Info. Ich prüfe den Pre-Load nochmal. Ansonsten scheint ja die Statify-URL nicht beim Laden zu stören.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Ladezeit-Problem?!’ is closed to new replies.