WordPress.org

Support

Support » Plugins and Hacks » [Resolved] JW6 Shortcodes

[Resolved] JW6 Shortcodes

  • Tifa
    Member

    @mardie

    Hi,

    The new jwplayer 6 works great but have some issues.

    1.) I want to clarify something. The old code will no longer work. Example:
    [jwplayer config="audio" file="http://mylink.com/myfile.mp3"]

    Question 1: We need to use the “add external” media first then insert it to post? Coz the old “file” would not work?

    2.) Its related to 1 above. The file=”link” seems to work but does not work together with the skins. Whether I use config=”audio” or playerid=”3″ . It only uses the default one. But when I remove the file=”link” and use mediaid=”1″ the skins show. Btw, we upgrade to premium, so we can change skins via settings.

    3.) Some config=”” settings gives an error “skin missing”. I know its incompatibility from JW5, but we already have a lot of shortcode embeds on our site and this is kinda annoying to change all of them.

    4.) The video works great on IOS but the audio only does not. the width & height is like a video. Even if I add height=”24″ it does not take effect in IOS, is there a solution to this?

    Thanks in advance

    http://wordpress.org/extend/plugins/jw-player-plugin-for-wordpress/

Viewing 15 replies - 1 through 15 (of 23 total)
  • Plugin Author JW Player
    Member

    @longtail-video

    Please provide a link to an example. This way we can help debug.

    Tifa
    Member

    @mardie

    I sent an email on support and got answers.

    Plugin Author JW Player
    Member

    @longtail-video

    Great!

    What was the solution to getting an audio-only file to display properly in iOS? I am having the same problem, where an mp3 file with a height of 24 displays properly on a desktop, but on an iPhone it is too large, like a video – just as you said.

    Plugin Author JW Player
    Member

    @longtail-video

    This is an issue that we are going to fix with an upcoming player release. We set a min height on devices so right now a controlbar only implementation is not possible.

    How do I convert the following short code for a video player in version 5 to jw player 6?

    [jwplayer config=”player” image=”http://jobracketbreakout.net/images/beartrapeatsmoney.jpg” html5_file=”http://jobracketbreakout.net/videos-jobb/Trap_Trade_Instructions.mp4″]

    Plugin Author JW Player
    Member

    @longtail-video

    [jwplayer image=”http://jobracketbreakout.net/images/beartrapeatsmoney.jpg” sources=”{ file: ‘http://jobracketbreakout.net/videos-jobb/Trap_Trade_Instructions.mp4′},{ file:’http://jobracketbreakout.net/videos-jobb/Trap_Trade_Instructions.mp4’}”]

    I tried that shortcode, the video player comes up with the image displayed, but the when I click on the play button, it shows the spinning wheel like it is loading, but nothing else happens.

    Plugin Author JW Player
    Member

    @longtail-video

    Do you have a link?

    Funny, I just used that and it worked this time. I noticed the 0 and 1 with the HD options. Can you let me know what each one is?

    Plugin Author JW Player
    Member

    @longtail-video

    If you are just using two files, then I would recommend updating the player to 6.8, there won’t be a menu, just hd on or off.

    Edit this file – jwplayermodule.php

    And change:

    define(“JWP6_PLAYER_LOCATION”, null);

    To:

    define(“JWP6_PLAYER_LOCATION”, “http://p.jwpcdn.com/6/8/jwplayer.js”);

    One more question. Enounce was working with JW5, but now our customers are having problems getting it to function with JW6. Any ideas / help would be appreciated.

    Plugin Author JW Player
    Member

    @longtail-video

    What is Enounce?

    http://www.enounce.com/

    THis is a program that allows you to change the playback speed of videos.

    Plugin Author JW Player
    Member

    @longtail-video

    This can be done by using our JS API – http://www.jwplayer.com/blog/slow-motion-with-jw-player/

Viewing 15 replies - 1 through 15 (of 23 total)
  • The topic ‘[Resolved] JW6 Shortcodes’ is closed to new replies.