Support » Plugin: Tera Charts » JSON parse error

  • Hi,

    I can see the interfase, but whenever I try to upload a file I get the following:

    Error: SyntaxError: JSON.parse: unexpected character (2.xls)

    BTW, the file “2.xls” is actually “zmbl2.xls”, I don’t know why it changes the filename.

    I’ve tried this with several files, both .xls and .xlsx, and still get the same error, and the name changing in the error.

    Also, why can I only see 3 chart types in the drop-down menu (zoomable treemap, reingold tree, sunburst), when I see the .xls samples for many other chart types??

    Also, any chance to display individual charts through shortcode?

    Many thanks!!

    http://wordpress.org/plugins/tera-charts/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author clickdeal

    (@calberti)

    Hi
    this type of error is usually due to the use of a wrong xls input file. Are you sure you are using the proper template? Have you tried with the example file? Please remember that only one file can be used with each visualisation.
    The additional xls files are there only as a reference for the other visualisations available in the pro version.
    A demo is available here:
    http://www.wpbusinessintelligence.com/showcase/tera-charts-demo/

    Yes I am downloading the template file, saving it, and reuploading it to use it as data.

    Still get the same errors and namechanges.

    Many thanks

    Greetings,
    Below is the error I get when uploading any of the provided excel templates included with the plugin. Any help would be appreciated.
    Thanks

    <b>Warning</b>: Missing argument 4 for excel2JSON::buildHierarchy(), called in C:\xampp\htdocs\wp-content\plugins\tera-charts\charts\excelMapClass.php on line 356 and defined in <b>C:\xampp\htdocs\wp-content\plugins\tera-charts\charts\excelMapClass.php</b> on line <b>315</b>

    Plugin Author clickdeal

    (@calberti)

    Hi, can you please try this demo and let me know if it works for you?

    http://www.wpbusinessintelligence.com/showcase/tera-charts-demo/

    I will check if there’s any difference in the two version.
    cheers,
    Claudio

    Hello Claudio,

    where can I found a proper template for trying the pluggin? I look like the link is broken.
    thanks so much!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘JSON parse error’ is closed to new replies.