WordPress.org

Support

Support » Plugins and Hacks » [Resolved] JS errors in WPAdmin when 2.7 is enabled

[Resolved] JS errors in WPAdmin when 2.7 is enabled

  • anobjectn
    Member

    @anobjectn

    Just enabling the 2.7 version and I get the following error in any WP Admin page:

    firefox:
    TypeError: $(…).on is not a function
    http://mydomain.com/wp-content/plugins/social/assets/admin.js?ver=2.7
    Line 180

    Chrome:
    Uncaught TypeError: Object [object Object] has no method ‘on’ admin.js:180
    (anonymous function) admin.js:180
    e.resolveWith load-scripts.php:2
    e.extend.ready load-scripts.php:2
    c.addEventListener.C

    Race condition? Running at innaprop time? Are there known conflicts with other plugins?

    As you can imagine, the error causes problems using unrelated features of WP Admin like the WYSIWYG post editor, Gravity Forms editing, Pods functionality.

    As soon as I disable Social 2.7 these other problems disappear.

    Line 180 looks like: $('.broadcast-interstitial .broadcast-edit textarea').on('keyup change click focus', function() {

    Any tips, pointers, theories?

    Thank you

    http://wordpress.org/extend/plugins/social/

Viewing 1 replies (of 1 total)
  • Plugin Contributor Alex King
    Member

    @alexkingorg

    Sounds like another plugin isn’t playing nicely – the version of jQuery that ships with WP core includes “on”.

Viewing 1 replies (of 1 total)
  • The topic ‘[Resolved] JS errors in WPAdmin when 2.7 is enabled’ is closed to new replies.