Support » Plugin: Jigoshop » jigoshop SSL checkout error

  • Resolved Rob Goodwin

    (@aboutwd)


    I was getting the dreaded “Sorry, your session has expired.” error message at checkout. (using Jigoshop, Stripe) I still haven’t been able to fix it.

    In an effort to find a solutions for this, I turned off the “WordPress HTTPS” plugin (Now I get errors with ‘mixed SSL’ content, so it’s not a permanent solution). However, I now get this error when trying to check out with Jigoshop/Stripe.

    “The Stripe payment gateway encountered an error while trying to process your payment. Please try again. You passed an empty string for ‘card’. We assume empty values are an attempt to unset a parameter; however ‘card’ cannot be unset. You should remove ‘card’ from your request or supply a non-empty value”

    Any Ideas? Or better yet, how can I turn on the “WordPress HTTPS” plugin without getting the “Session Expired” message?

    WordPress 3.9.1
    Jigoshop 1.9.5
    Stripe Gateway for Jigoshop 1.2.2 (Which I’ll be getting a refund for if I can’t find a solution to this soon.)

    Please help.

    https://wordpress.org/plugins/jigoshop/

Viewing 15 replies - 1 through 15 (of 22 total)
  • Plugin Author Jigoshop Support – Paul

    (@paulpreston)

    Jigoshop Support Rep

    Hi Rob,

    Please check if “Force SSL on checkout” is enabled in Jigoshop –> settings –> General

    Can you send us login details to support(at)jigoshop.com?

    Yes, when I have “Force SSL on Checkout” checked, I get browser warnings that not all of my resources are secure (widget images are being pulled through http, etc). And yes, this error “empty string for ‘card'” happened when “Force SSL on Checkout” was checked.

    Of course turning that OFF completely shuts off the Stripe payment plugin anyway, so there’s no way it could have been off.

    That “Force SSL” also causes other problems. For one customers can’t ever get back to the HTTP version as all of the links have been converted to HTTPS. I installed WordPress HTTPS to combat that problem. (which gives me a “Sorry, session expired” error on checkout)

    Thoughts?

    Here’s a JPG image of what my log entries look like in my Stripe Account.

    NOTICE: the Card field is in fact actually blank.

    Image here

    Plugin Author Jigoshop Support – Paul

    (@paulpreston)

    Jigoshop Support Rep

    Please try relative urls not absolute and it will be fine. It’s a theme issue as far as I can tell.

    If that doesn’t work please send us login details to support@jigoshop.com

    I’m sorry, “relative URLs” where? If you mean in my misc site images, that might solve the mixed content issue, but certainly doesn’t get the plugin working (as far as I can see).

    Or am I missing what you’re trying to say?
    Thanks

    Plugin Author Jigoshop Support – Paul

    (@paulpreston)

    Jigoshop Support Rep

    Stripe is being used by many clients, I’m surprised that there is an issue on one website.

    Please send us login details to support@jigoshop.com and we will look into it.

    Yeah, I’m sure it’s a good plugin. I just can’t get it to work for anything. Disabled all my plugins… no go. I’m not sure what to do at this point.

    Plugin Author Jigoshop Support – Paul

    (@paulpreston)

    Jigoshop Support Rep

    Rob,

    Our lead developer is on the case and he will update you shortly.

    Plugin Author Jigoshop Support – Paul

    (@paulpreston)

    Jigoshop Support Rep

    Hi Rob,

    Please update to 1.9.6, clear the cache and check it again.

    Thanks. I updated to 1.9.6, cleared the cache and attempted several transactions (with different cards)… still the same message.

    “You should remove ‘card’ from your request or supply a non-empty value”

    Plugin Author Jigoshop Support – Paul

    (@paulpreston)

    Jigoshop Support Rep

    Ok, please change your theme to http://wordpress.org/themes/twentythirteen and check if you experience the same issue?

    Yes, same error message using 2013 theme. But I do appreciate the troubleshooting.

    Plugin Author Jigoshop Support – Paul

    (@paulpreston)

    Jigoshop Support Rep

    Rob,

    In which case we will have to look into it on your website

    Thanks for your help. I have sent an admin username/password to your support email address. I hope a solution can be found.

    Brand new empty database
    Fresh install of WordPress
    Fresh install of Jigoshop
    Fresh install of Stripe plugin

    Still the same error “You should remove ‘card’ from your request or supply a non-empty value”.

    It’s probably some server setting or something, but I give up.
    I really wish it had worked.

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘jigoshop SSL checkout error’ is closed to new replies.