WordPress.org

Forums

Easy FancyBox
[resolved] javascript error when the plugin is activated (6 posts)

  1. hannakost
    Member
    Posted 2 years ago #

    hello everyone,

    I've download the plugin as a .zip file, extracted it, and uploaded the files to a new folder in my /plugin folder. then I activated the plugin via the wp-admin, but when the plugin is activated all of my .js files don't work because of a problem.
    it seems that the problem is here:
    jquery.easy-fancybox-1.3.4.pack.js, in line 18, the error message is: "can't read property 'msie' of undifined".

    Hope that you can help me with it.
    thanks

    http://wordpress.org/extend/plugins/easy-fancybox/

  2. RavanH
    Member
    Plugin Author

    Posted 2 years ago #

    Hi Hanna, could you share a link to the site where this error is occurring?

  3. Stav Pan Geffen
    Member
    Posted 2 years ago #

    I came across that msie error with another lightbox plugin i used- it has something to do with a deprecated method jquery.browser method.

    They're dropping support of old ie versions, so old method will become unknown to browsers with the latest jquery.

  4. Nex Otaku
    Member
    Posted 2 years ago #

    Yes, this is due to incompatibility of Fancybox with new jQuery.

    My theme loads jQuery 1.9.0 and Fancybox gives errors:
    b.browser is undefined in Firefox,
    Cannot read property 'msie' of undefined in Chrome.

    Changed jQuery to 1.8.0, error is gone.

    Please fix.

  5. RavanH
    Member
    Plugin Author

    Posted 2 years ago #

    A fix is planned. I hope to have time to implement it before WordPress 3.6 is released...

  6. hannakost
    Member
    Posted 2 years ago #

    Oh, thanks,
    I changed to 1.8.3 and it works now, but I have other problems with two jQuery plugins I have....

    Thanks again :-)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic