Support » Plugins and Hacks » Google Language Translator » [Resolved] Javascript error

[Resolved] Javascript error

  • Hi,

    Plugin: Google Language Translator | Version 3.0.9

    I am having some javascript errors/conflicts on a site and have found the following:

    Uncaught TypeError: Object [object Object] has no method ‘on’
    event.returnValue is deprecated. Please use the standard event.preventDefault() instead.

    This comes from the following: load-toolbar.js?ver=3.8.1:5 [I have highlighted Line 5 in bold.

    jQuery(document).ready(function($) {
    $(‘#glt-translate-trigger’).toolbar({content: ‘#glt-toolbar’, position: ‘top’, hideOnClick: ‘true’});
    $(‘#glt-translate-trigger’).on(‘toolbarShown’,function(event) {

    The conflict I am having is with plugin: http://wordpress.org/support/plugin/imagemapper

    Any help you can offer is much appreciated.

    Thank you


Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Rob Myrick


    Thanks JamesICT, let me check into this – I’m sorry for the delay. I will try and have a reply here in a day or two.

    Does the plugin not work at all for you? Or do you just have this error with no problems?

    Let me know. Thanks!


    Hi Rob,

    I have made some other changes on the site and the error message is no longer appearing.

    Thank you for your reply.

    Plugin Author Rob Myrick


    Hi JamesICT, I will mark this as resolved.

    Would you mind sharing the solution here for other (and myself) to understand? I have not yet experienced this sort of conflict.

    Thanks! Rob

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Resolved] Javascript error’ is closed to new replies.