Support » Plugin: BSK Gravity Forms Blacklist » Javascript Error

  • Resolved James

    (@bonkerz)


    Getting this error

    TypeError: undefined is not a function (near '...$(".bsk-pdfm-selector-pdfs-dropdown").live...')

    in bsk-gfbl.js: line 12.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Hey there bonkerz. This happened to me after updating to 2.1… I feel like I’ve had to fix this before, even though the changelog states that this issue was fixed in 2.0.

    Here’s how you can fix it:

    Open the file bsk-gfbl.js located in /wp-content/plugins/bsk-gravityforms-blacklist/js/

    Line 12 should look like this:
    $(".bsk-pdfm-selector-pdfs-dropdown").live("change", function(){

    Simply change “.live” to “.on” like this:
    $(".bsk-pdfm-selector-pdfs-dropdown").on("change", function(){

    Save the file and you should be good to go.

    Thanks that solved it!

    Plugin Author bannersky

    (@bannersky)

    Thanks for your help about this plugin. The error has been fixed from version 2.2 and you may upgrade to the new version now.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Javascript Error’ is closed to new replies.