Support » Plugin: Grids: Layout builder for WordPress » Javascript API error when using Grids on custom post type

  • Resolved gdalrymple

    (@gdalrymple)


    Hi there,

    Love the plugin but I think I’m experiencing a bug when using the Grids plugin on a custom post type.

    In the admin a 404 error is returned from the api-fetch.js file.

    .../wp-json/wp/v2/types/5328?_locale=user

    In my case my custom post type is called solutions in which case the API url should be…

    http://mysite.com/wp-json/wp/v2/solutions/5328

    I think this error is having a side effect of not being able to save gutters from the overall Grids setting panel. I’m using a custom built theme but I’ve tested this with the default themes and the same issue occurs.

    Thanks,
    Greg

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Contributor simo_m

    (@simo_m)

    Hi Greg,

    thanks for reporting, we are working on a fix that will be released as soon as possible.

    Regards,

    Simone

    Plugin Contributor Andrea Gandino

    (@andg)

    Hey @gdalrymple,

    we have just released an update to the plugin that should fix the issue you reported. Can you confirm that?

    Thanks,

    Andrea

    Thread Starter gdalrymple

    (@gdalrymple)

    Hi @andg,

    That’s great thanks for the quick response. I’ve updated the plugin and the error is gone but it still doesn’t seem to save the gutter value from the settings panel.

    And it’s also printing out values to the console now every time a key is pressed when entering values into the gutter field.

    Thanks,
    Greg

    Plugin Contributor Andrea Gandino

    (@andg)

    Sorry about the log to console, we’ll fix that!

    In regard to not saving the gutter value, that’s a meta field for the post type, so you’ll need to make sure that your Custom Post Type has support for custom-fields.

    Thread Starter gdalrymple

    (@gdalrymple)

    Ah ok, I didn’t realise that.

    Thanks very much, all seems to be working now!

    Greg

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Javascript API error when using Grids on custom post type’ is closed to new replies.