Support » Plugins and Hacks » SSL Insecure Content Fixer » Issue with a few plugins

  • Resolved erryn

    (@erryn)


    Hi there;

    Firstly nice work on the plugin! I’m having a couple of issues with plugins however which this does not apply to, one is Jquery Mega Menu, the other is social media tabs. I can see in the Mega Menu file it’s using get_plugin_directory() which returns WP_PLUGIN_URL/menu plugin path.

    I thought in my naivity that WordPress should be able to handle https on WP_PLUGIN_URL dynamically, however I’m still getting issues (the website is just-garden-games.co.uk, if you chuck in https: you will see what I mean).
    Any thoughts?

    http://wordpress.org/extend/plugins/ssl-insecure-content-fixer/

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author webaware

    (@webaware)


    G’day,

    I can’t see the site, it just redirects to just-online.org, so I’m afraid I can’t help diagnose what’s going on here.

    cheers,
    Ross

    Apologies, it needs the www. (thanks for pointing that out, i will go fix that now) 🙂

    Fixed now, left it out of the multi-site domain mapping…

    Plugin Author webaware

    (@webaware)


    Right, you’re running WordPress 3.3.1 — really old, obsolete, time to upgrade. When you do, WP_PLUGIN_URL will return an HTTPS address.

    My plugin isn’t fixing that menu plugin because they’re loading their scripts too late, after I clean up all the scripts that should be loaded already. Specifically, they’re loading their scripts on action wp_head, instead of wp_enqueue_scripts which is what they’re meant to be using. Tell them to fix their plugin 🙂

    cheers,
    Ross

    Hi again, (thanks for the swift response by the way, kudos to being on the ball!

    It’s actually Version 3.5.2 (just masked on the front-end), cheers for the insight, I should be able to go in and mod the plugin files so they use the enqueue script (hopefully!) 🙂

    Plugin Author webaware

    (@webaware)


    Good stuff, glad you got it all sorted.

    cheers,
    Ross

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Issue with a few plugins’ is closed to new replies.