Support » Plugin: SG Optimizer » Issue with Minify CSS Files option and CSS Custom Properties

  • creativethemeshq

    (@creativethemeshq)


    Hello team,
    We recently discovered that if the Minify CSS Files option is enabled it starts to remove the unit from a CSS Variable fallback.

    It should be like this margin: var(--margin, 0px) but when this option is enabled it makes it like this margin: var(--margin, 0) – without unit.
    To be honest this is a bad practice to remove the unit.

    In some cases where we make calculations with calc() – this breaks everything because the calc function doesn’t know what units to take in consideration.

    Could you please take a closer look on this and let us know if you could fix this issue?

    Thank you.

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Stanimir Stoyanov

    (@sstoqnov)

    SiteGround Representative

    Hey,

    We will check the issue and will try to provide a fix soon.

    Regards,
    Stanimir

    Thread Starter creativethemeshq

    (@creativethemeshq)

    Hey @sstoqnov, thanks for your help!

    Thread Starter creativethemeshq

    (@creativethemeshq)

    Hey guys (@sstoqnov, @hristo-sg) why did you marked this issue as solved?
    It is still not solved, a lot of our users still have the problem with the Minify CSS Files option.

    Please take a closer look or let us know if there is something we could help you with to resolve it.

    Thank you!

    Plugin Author Stanimir Stoyanov

    (@sstoqnov)

    SiteGround Representative

    Hey @creativethemeshq

    We are currently working on this issue and we will update the ticket when it’s fixed and a new version is released.

    Regards,
    Stanimir

    Thread Starter creativethemeshq

    (@creativethemeshq)

    Hello @sstoqnov,
    Thanks for letting me know, will wait a message from you.

    Plugin Author Stanimir Stoyanov

    (@sstoqnov)

    SiteGround Representative

    Hey @creativethemeshq

    Would it be possible to give an example that is being minified wrong?

    Regards,
    Stanimir

    Thread Starter creativethemeshq

    (@creativethemeshq)

    Hello @sstoqnov,
    For example we have a css value like this margin: var(--margin, 0px) with a default value of 0px but when the Minify CSS Files option is enabled it removes the unit and the result turns like this margin: var(--margin, 0), this is bad in some cases when you make calculations with css calc() function.

    Let me know if you need more help or info.

    Thread Starter creativethemeshq

    (@creativethemeshq)

    Hi @sstoqnov,
    Any updates on this?
    We have a lot of users that have this issue with your plugin.

    Maybe you could dedicated some time to it and add a fix as it’s already 2 months since I reported this bug.

    What do you think?

    Hello SiteGround,

    I have more than twenty WordPress websites hosted with SiteGround and have implemented Blocksy as an excellent site development tool. I’ve had the problem described in this thread with the SG Optimizer plugin causing issues with one of my websites created with Blocksy. Specifically, the SG Optimizer was preventing my website from displaying at full screen width. There is a workaround that involves turning off some of the SG Optimizer functionality, however I’d prefer not to have to tweak these settings every time I use Blocksy for one of my websites.

    I really like SG hosting for WordPress and the SG Optimizer provides a great many features that typically require multiple plugins. I really hope this issue can be resolved.

    Thank you,
    Brian

    This is important to me too. Blocksy is the foundation of ALL my current projects, and one of the handful of leading-edge themes attracting most notice right now. I really need this fixed.

    (I’m also a huge fan of SiteGround and your truly excellent support — this is the first troubling issue I’ve had. I need to know that SG Optimizer won’t make any breaking changes to my work.)

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.