Support » Plugin: Permalink Manager Lite » Issue when using wp-all-import

  • Resolved pratham2003

    (@pratham2003)



    Hi,

    There is an issue with permalinks when using wp-all-import plugin.

    When we run an import using wp-all-import’s cron method, the imported pages start returning 404 error.

    We have disabled permalink-manager on this particular post_type but in permalink-manager’s debug tab we still see entries being generated for this particular post_type under ‘Array with URIs’.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Looks like the issue is with the following function in your plugin, it doesn’t validate the post type?

    pmxi_fix_permalinks

    Can you please let me know a way to remove the following action hook from outside your plugin?

    add_action('pmxi_after_xml_import', array($this, 'pmxi_fix_permalinks'), 10);

    i.e. what instance variable do I pass in the following?
    remove_action('pmxi_after_xml_import', array(???????????, 'pmxi_fix_permalinks'), 10);

    Plugin Author Maciej Bis

    (@mbis)

    Hi Pratham,

    I fixed that in 2.1.2 version. It is not officially released yet but you can download dev version from here:
    https://downloads.wordpress.org/plugin/permalink-manager.2.1.2.zip

    Now “Excluded post types” (“Disable Permalink Manager functionalities” option in Permalink Manager settings) settings are applied also to WP All Import functions + there is a new option: “Disable support for WP All Import” in Permalink Manager settings.

    Best regards,
    Maciej

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.