Support » Plugin: WP-ISPConfig 3 » Issue soap

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author ole1986

    (@ole1986)

    @wpmicronet

    pretty sure that does not have something to do with the wordpress plugin rather than the ispconfig web configuration.

    As you can see from the following page:
    https://www.faqforge.com/linux/which-ports-are-used-on-a-ispconfig-3-server-and-shall-be-open-in-the-firewall/

    Ispconfig web interfaces uses port 8080 by default (if you have not changed it)

    So, I assume it might have something to do with the correct hostname.

    Hello,

    I changed the default port of ispconfig I use another port,
    The hostname and (Subdomain.Domain) are properly configured that points to my ispconfig server.

    From the WooCommerce products page, I have this message:
    “ISPConfig SOAP Request failed: Could not connect to host”

    Is there anything that should appear on the page,
    When you type the url below, from a web browser ?

    https://subdomain.domain:2053/remote/index.php
    or
    https://subdomain.domain:2053/remote/

    Cordially.

    Plugin Author ole1986

    (@ole1986)

    @wpmicronet

    At least it should show you an “empty” page returning status code 200.
    You can check it from the following page:

    https://httpstatus.io/

    Just put https://subdomain.domain:2053/remote/index.php into it and press submit.
    Result should be Status Code 200

    I have a status code 200,

    I always get the message in WooCommerce products:
    “ISPConfig SOAP Request failed: Could not connect to host”

    Cordially

    Plugin Author ole1986

    (@ole1986)

    @wpmicronet

    It must have something to do with the connection to the host.
    So, please be very sure the address is properly entered in “WP-ISPConfig 3 -> Settings”:

    SOAP Location:
    https://yourserver:2053/remote/index.php in

    SOAP URI:
    https://yourserver:2053/remote/

    Also make sure your certificate is valid when using HTTPS (SSL).

    If you want to bypass the certificate verification you can try changing the file “ispconfig.php” in LINE 38:

    
    public function withSoap(){
        $context = stream_context_create([
            'ssl' => [ 
                'verify_peer' => false,
                'verify_peer_name' => false,
                'allow_self_signed' => true
            ]
        ]);
        $this->soap = new SoapClient(null, [
            'location' => WPISPConfig3::$OPTIONS['soap_location'] , 
            'uri' => WPISPConfig3::$OPTIONS['soap_uri'], 
            'trace' => 1, 'exceptions' => 1, 
            'stream_context' => $context
        ]);
        $this->session_id = $this->soap->login(WPISPConfig3::$OPTIONS['soapusername'], WPISPConfig3::$OPTIONS['soappassword']);
            return $this;
        }
    
    • This reply was modified 2 years, 6 months ago by ole1986.
    • This reply was modified 2 years, 6 months ago by ole1986.
    • This reply was modified 2 years, 6 months ago by ole1986.

    Here is what I have in my ispconfig.php file:


    //* Allow connections to self signed SSL certs
    $context = stream_context_create(
    array(
    ‘ssl’ => array (
    ‘verify_peer’ => false,
    ‘verify_peer_name’ => false,
    ‘allow_self_signed’ => true
    )
    )
    );

    $client = new SoapClient(null, array(‘location’ => $_POST[‘remote_server’],
    ‘uri’ => $_POST[‘remote_server’].’/index.php’,
    ‘trace’ => 1,
    ‘exceptions’ => 1,
    ‘stream_context’ => $context));

    if($remote_session_id = $client->login($_POST[‘remote_user’], $_POST[‘remote_password’])) {
    $connected = 1;
    $msg .= ‘Successfully connected to remote server.’;
    }
    } catch (SoapFault $e) {
    //echo $client->__getLastResponse();
    $error .= $e->getMessage();
    $connected = 0;

    Plugin Author ole1986

    (@ole1986)

    Well, the ispconfig.php you are showing to me is not the original as it uses (for some unknown reason) $_POST['XXXXXXXX'] parameters instead of WPISPConfig3::$OPTIONS

    So, i highly recommed to “reinstall” the plugin…

    On the ispconfig.php file I have remove :

    ” public function withSoap(){
    $this->soap = new SoapClient(null, [‘location’ => WPISPConfig3::$OPTIONS[‘soap_location’] , ‘uri’ => WPISPConfig3::$OPTIONS[‘soap_uri’], ‘trace’ => 1, ‘exceptions’ => 1]);
    $this->session_id = $this->soap->login(WPISPConfig3::$OPTIONS[‘soapusername’], WPISPConfig3::$OPTIONS[‘soappassword’]);
    return $this;
    }”

    ———————-

    I put what you wrote above:

    “public function withSoap(){
    $context = stream_context_create([
    ‘ssl’ => [
    ‘verify_peer’ => false,
    ‘verify_peer_name’ => false,
    ‘allow_self_signed’ => true
    ]
    ]);
    $this->soap = new SoapClient(null, [
    ‘location’ => WPISPConfig3::$OPTIONS[‘soap_location’] ,
    ‘uri’ => WPISPConfig3::$OPTIONS[‘soap_uri’],
    ‘trace’ => 1, ‘exceptions’ => 1,
    ‘stream_context’ => $context
    ]);
    $this->session_id = $this->soap->login(WPISPConfig3::$OPTIONS[‘soapusername’], WPISPConfig3::$OPTIONS[‘soappassword’]);
    return $this;
    }

    —————————–

    But I still have the message :
    ISPConfig SOAP Request failed: Could not connect to host

    Cordially

    Plugin Author ole1986

    (@ole1986)

    If you agree I can test it from my machine by giving me the soap url and remote user / password combination.

    To keep your data confidential, you can write me an email to: ole.k at web.de

    I sent you by email soap url username remote password …

    Cordially

    Did you check that the ports out are open in the firewall? Contact your hosting provider to verify.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Issue soap’ is closed to new replies.