Support » Plugins and Hacks » [Resolved] Events Calendar and WordPress 3.0

[Resolved] Events Calendar and WordPress 3.0

  • hello,
    i am getting this error:

    Fatal error: Cannot redeclare is_rtl() (previously declared in /var/www/web1503/html/wp_mu/wp-includes/locale.php:347) in /var/www/web1503/html/wp_mu/wp-includes/locale.php on line 349

Viewing 15 replies - 1 through 15 (of 24 total)
  • I just upgraded to 3.0 and am getting the exact same thing.. I tried to comment out the is_rtl() in local.php but got a different error after that, so I put it back..

    My site is hosed until I get this fixed..

    Anyone? Please?

    Ah I found some info that it is related to the events-calendar plugin.. I moved it out and was able to bring the site back online..

    now to go find a 3.0 compatible events calendar plugin

    Well. Thank goodness for the Forum! Thanks Mscroggi, at least that’s one fishing expedition less. Now, onto another, as you put it: to find a 3.0 compatible events calendar plugin…

    Moderator Andrew Nacin


    Lead Developer

    This is due to the events-calendar plugin loading the blog locale too early, instead of just letting WordPress load it when it is ready.

    In 2.9, it silently caused errors underneath relating to RTL/LTR, translations, locale, etc. In 3.0, due to an unrelated change, it’s making a bit more noise failing.

    Sweet Jaysus, this was helpful. THANKS! If/when y’all find a 3.0 compatible events calendar plugin, can you post to this thread?

    Moderator Andrew Nacin


    Lead Developer

    Moderator James Huff


    If you run into this error, reset your plugins and do not reactivate Events Calendar.

    See nacin’s first reply for an explanation.

    Hardly a user-friendly method. In this case, because the culprit is known, there is a much simpler way to regain control: just rename the specific plugin’s folder, from ozh-admin-drop-down-menu to (say) OLD-ozh-admin-drop-down-menu then clear your browser cache, reload either the plugin or admin main index page, and you’re done – the plugin is deactivated because it can’t be found.

    Using phpMyAdmin for the situation here is plain overkill.

    I know about this and working in this. I hope to have a solution tomorrow. Hopefully with 7.0.


    But I really should have some coffee next time before I post… I mean, just look at the example folder name I used above! Can you guess which other plugin gave me some 3.0 upgrade grief today? Oh well.

    Hi guys – if you are in need of a quick fix before 7.0 comes out and need to have the calendar work with WordPress 3.0 – you can see my fixes that I submitted over here. Read each post as it explains what changes are necessary to allow the Large Calendar to work.


    I just had a similar issue when I upgraded one of my clients’ sites. Same deal.

    So when is this going to be all ready for 3.0 without requiring code hacks?

    Thanks so much. I just deleted the plugin folder for the events calendar. It was deactivated anyways. And that got me back in. Thank you, Thank you!


    I made a zip of the trunk SVN code just now, if you want an easy option download this and unzip in your plugins folder http://www.nzlinux.com/files/events-calendar.zip(for the less clued up)

Viewing 15 replies - 1 through 15 (of 24 total)
  • The topic ‘[Resolved] Events Calendar and WordPress 3.0’ is closed to new replies.