Support » Plugin: Lingotek Translation » Invalid user specified.

  • Hi, does anybody know how do I fix this error?
    When I click on the pencil image to update the translation I am redirected to a “Invalid User Specified” message but I can log in with my email and password, can anyone help with this?
    Thanks

Viewing 2 replies - 1 through 2 (of 2 total)
  • earendel

    (@earendel)

    Yes, I just fixed it.

    When you activate a lingotek account, an email address is requested from you. That must be the same email address assigned to the WordPress user that is currently editing the page translations.

    When you click on the pencil you get redirected to lingotek webpage and it accesses by using your Lingotek Login Id (saved in the plugin settings) and the access token (automatically generated and stored in the settings).

    For some reason in the query string it appears the Lingotek login id (info@mywordpresssite.net in the example below) AND the email associated to the current WordPress user (mypersonal.email@gmail.com) as “acting_login_id”:

    ...&login_id=info%40mywordpresssite.net&acting_login_id=mypersonal.email%40gmail.com&...

    That gave me the idea that probably the “acting_login_id” was used for authentication instead of the “login_id” or that for some reason they had to match.

    As soon as I changed the WordPress user email address to the one used as Lingotek username, it all worked.

    That looks quite like a bug to me because I would want all my editors to be able to review the translations and not only the WordPress user of which the email has been used as Lingotek account username (considering that such user may even not exist).

    • This reply was modified 7 months ago by earendel.
    • This reply was modified 7 months ago by earendel.

    I’m not sure it’s a bug.
    You can change the Login id of the Lingotek user (default: Login id is the same as the user’s email).
    Alternatively, you can create another community member for the same project which has the same email you use on you’re currently logged in WordPress user you’re using to edit translations.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Invalid user specified.’ is closed to new replies.