WordPress.org

Support

Support » How-To and Troubleshooting » “Internal Server Error”

“Internal Server Error”

  • When writing a post about a new WordPress plugin I’ve developed (a Xanga/Wordpress crossposter), I ran into the weirdest error I have ever met in my experience with computers. I have no clue what causes it, so I’m posting here for ideas.

    When I clicked “Save as Draft” after finishing the entry, my server did not save it, but instead returned an error 500 — Internal Server Error. This is a regularly seen message in Perl coding, but not in PHP. Since I had just uploaded a slight code change to my plugin, I thought that was the cause, thinking I had just made a typo in my code. It turns out it isn’t quite so simple. I couldn’t find any typos, so I completely disabled my plugin and the error still occurred.

    On a hunch, I tried removing all but a little bit of my entry text, and it worked! I then added the whole entry back in, bit by bit, until I found the offending part. It turns out that the two-word phrase “Perl for” crashes WordPress. It doesn’t matter if it is in the post title or body, what the context is, or whether it is capitalized. I know that the problem is in WordPress itself (at least my installation), because the problem occurs with all plugins deactivated.

    Does anybody have any idea why WordPress is allergic to the phrase “perl for”?

    FYI, I am using WordPress 1.2.

Viewing 15 replies - 1 through 15 (of 22 total)
  • Well, to my limited knowledge, I would think that an “internal server error” has more to do with how your server is processing the PHP and not so much that WordPress can’t handle that particular phrase.

    1.5 here….and I just posted that without a problem……

    Odd !

    It may just be my server. I don’t have another server up and running to test it on, and don’t have time to set one up just for that. 😉

    Internal Server Errors can also be generated when a PHP script attempts to do something not allowed by the operating system that is not caught by PHP itself. For example, in certain situations, you can get Error 500s when you attempt to access or write to files with improper permissions.

    I was getting the same problem a couple weeks back but it just went away!

    I am having the exact same problem. This just started in the last couple days. I’ve been using WP for almost 2 months now.

    Moderator James Huff

    @macmanx

    Guys, an internal server error is something that happens internally …in your server. Therefore, the actual error is placed inside your server error log. Without knowing what that error is, we can’t say what’s going wrong. Saying that you have an “internal server error” is equivalent to saying that you don’t feel well without describing the symptoms.

    I just did a simliar “test” removing one word at at time to see when it crashes. For me it was the word “form”. If I removed this word from my entire post the Save and Continue Editing features works fine. When I add “form” back in, it crashes.

    There is no coding or special characters around form, nothing like (form) or <form>. Just the inclusion of the word is crashing WP and giving me an interal server error. Hmm…this is very weird.

    I have requested a copy of the 500 error from my ISP as I am unaware how to check this out. When I get it I will post this thread.

    Well…another interesting turn. I had a chance to look at all of my server errors – and there wasn’t anything in there that would indicate a problem with WP. It’s almost as if the error didn’t happen. There must be a “bug” somewhere in WP…but where I have no idea…

    Moderator James Huff

    @macmanx

    No, the error would have been deposited in your server error log. otherwise, you browser would not have displayed that “Internal Server Error” (which is always displayed after the error is written into the server error log). Try to recreate the error, then check your logs again.

    I’m getting server errors from this paragraph:
    Music is a bunch of waves in the air, and waves are continuous and very analog. When we digitize music, we cut it up in slices, 44,100 times in the case of a CD and try to pretend that we hear the same way we see. What I mean by that, is when you watch a movie, you see 24 frames per second of still pictures and you get the impression that it’s moving. When we slice music up 44,100 times per second, and expect our ears to fill in the blanks, it doesn’t work quite right. The reason is easiest to understand with very high frequencies, over 16,000 hz (a fancy way of saying cycles per second). Cymbals create sound in this range a lot. So we have a 20,000 cycle wave, and we sample it 44,100 times, picture a wave- with a high point and a low point and a mid-point- if we happen to sample only at the high point and the low point- we get the top and bottom of the wave- and we can cheat it a bit, and tell the components that it isn’t a zig-zag that we have to reproduce, but a wave- but if we sample at the midpoint each time- we get a straight line- and that, is noise.

    any ideas on what is causing this?
    Can you post it in your blog without an error?
    1.5

    I can post it, edit it and delete it. (1.5 stable)

    Get this- WordPress 1.5 won’t let me post anything with “CD” in it-
    I get a server error- change it to “Compact Disc” and it posts.

    Can someone please explain?

    so what’s even weirder- I can change Compact Disc back to CD in the first instance- and it crashes the server- server error-
    but if I go and put it at the end of the post- it allows it.
    Does anyone have any similar experiences of a single word causing the problem?
    I write my posts in MS Word- then copy and paste – so far everything else has worked.
    I thought it might have been being caused by Word formatting by doing the superscript “nd” as in 2nd- but that wasn’t it….
    thanks for checking it in other implementations ming.

    Word is really sneaking about adding extra junk. The easiest way to make sure nothing extra is present is to cut and paste from word to notepad to wp. Notepad stripes out all hidden formatting. Not sure if that’s the problem but give it a try just in case.

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘“Internal Server Error”’ is closed to new replies.
Skip to toolbar