Support » Plugin: GTPay Woocommerce Payment Gateway » integration problem

  • Hello,

    I have Installed GTPay to my WordPress website and activated it using merchant id and hash key.
    But, when I am trying to test GTpay payment option by placing order, It is not redirecting me to GTpay ,it simply redirects me to my website home page and order is not getting placed. I don’t know where i am going wrong. if anyone have idea about this please help

Viewing 5 replies - 1 through 5 (of 5 total)
  • Thanks in advance

    You need to change in gtpay-payment.php

    replace function by below code.

    function process_payment($order_id) {
                global $woocommerce;
                $order = new WC_Order($order_id);
                return array(
    	        	'result' => 'success',
    				'redirect'	=> $order->get_checkout_payment_url( true )
                );
            }

    Thank for the update, I have updated this and now I got to the point of redirecting me to gtpay and I got another error

    Server Error in ‘/OrangeLocker’ Application.
    The resource cannot be found.
    Description: HTTP 404. The resource you are looking for (or one of its dependencies) could have been removed, had its name changed, or is temporarily unavailable. Please review the following URL and make sure that it is spelled correctly.

    Requested URL: /orangelocker/gtpaym/tranx.aspx

    Any other suggestion?

    I’m currently facing this problem. Any advice?

    jekayode

    (@jekayode)

    Hello @jamesonkeju and @heywhydot16

    Open icludes/settings.php and update line 12 as below:

    "s_payment_endpoint" => "http://gtweb.gtbank.com//GTPay/Tranx.aspx",

    Let me know if this helps

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘integration problem’ is closed to new replies.