Support » Plugin: Developer Mode » installing new plugin's

  • Resolved joerallen


    So far your plugin has been working great. But I recently tried installing some new plugins and they will not show for me when I’m logged in as the developer, but if I log in as the administrator I can see them. I deleted all the DM plugin files, then added my new plugin, then re-installed the developer mode plugin and that seemed to work…hopefully you can look at this if you get some time.

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Contributor Jesper van Engelen


    What exactly do you mean with “they will not show for me”? Are you talking about the plugins overview page ( or are their menu items not showing in the menu (e.g. you install the Advanced Custom Fields plugin and it does not show up in the menu)?

    Any new plugin I install, will not show on the main menu bar (menu items) when I’m logged in as the “developer”. If I log in as an “Administrator”, I can then see the new install on the main menu bar. One of the plugins I installed is supposed to get a top level menu, and another one I installed just gets added to the “setting” menu directory. But neither will show to the developer role, only the admin role. Where on your site do I donate for this plugin?


    Plugin Contributor Jesper van Engelen


    That is strange. What plugins were installed? Are there any other plugins that could have caused the hiding of these menu items (such as Adminimize)? If you’re not sure, could you post a list of the plugins you have installed?

    As for donations: if you would like to donate, please do so to a charity :-). That would be great!

    I installed the plugin Tablepress….
    Here are the steps I did…

    -I uploaded the plugin “Tablepress” from my PC locally to the wp-admin plugins screen.

    – From there I activated the plugin

    – Once activated, I did not see any new top -level menus or sub menus.

    -I double checked my server plugins directory and the folder was there for Tablepress.

    – I then went to the Developer Mode admin screen and made sure this was view-able…and saved and refreshed my wp-admin…still no new plugin showing.

    -I logged out as the “Developer” and logged in as the “Administrator”, now I can see the new plugin…it has a top-level menu in wp-admin.

    – I deleted the plugin “Developer Mode”…logged out of the administrator, them logged back in under my normal user name.

    – I then reinstalled the “Developer Mode” plugin…claimed myself as “Developer”…and looked for the plugin Tablepress…now i can see Tablepress in my wp-admin….

    This is the only plugin that has acted this way…I’ve a couple others since then, and all have worked….so everything is good now!

    Big thanks for this plugin and generous follow-up support!

    Plugin Contributor Jesper van Engelen


    So just to be clear: the only plugin that causes this problem is the TablePress plugin? If so, I will look into the code of that plugin and see where the conflict arises.

    Plugin Contributor Jesper van Engelen


    I have analyzed the TablePress plugin, and it turns out it adds new capabilities – something I had not taken into account while programming for this plugin.

    I have released a new version of the plugin that automatically adds new administrator capabilities to the developer role!

    Thanks a lot for notifying me of this issue!

    I am also getting this message when I promoted myself to the developer role with

    WP Version 3.5

    Plugin Contributor Jesper van Engelen


    Corey, could you create a new support thread about this? I would like to know the version of the Developer Mode plugin you’re using.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘installing new plugin's’ is closed to new replies.