WordPress.org

Support

Support » Installation » Installation – Second Step.

Installation – Second Step.

  • I’ve got WordPress from wordpress.org/laatest.tar.gz and unzip it in my directory. After that, I write wp-config.php file and open my browser.
    Yes, before second step, there were no problems. But, when I’m on Second Step, browser is in loading status and does not progress any more.

    If I create table using MySQLAdmin or command line prompt, it’s just find.

    wp-config.php file alos just find. please help me~

Viewing 11 replies - 1 through 11 (of 11 total)
  • I’m not sure I understood you, but it sounds like you’re at the step where you’re creating the (a new) MySQL database.

    The concept is to only create the database (no tables or records). Then you configure wp-config to contain the details for accessing that new database…

    In the last step (6 – install.php) WordPress will fill/populate that database itself.

    Well, I have my own database already and ‘Second Step’ creates tables for WordPress.

    Again, installation doesn’t go futher. What a message I’ve got is:

    ——————————————————–
    Second Step

    Now we’re going to create the database tables and fill them with some default data.
    ——————————————————–

    What’s wrong??

    and ‘Second Step’ creates tables for WordPress.

    Obviously we are looking at different instructions.
    http://codex.wordpress.org/Installing_WordPress#Famous_5-Minute_Install

    I think, still, there’s a communication problem between us because of my bad English πŸ™‚

    I followed the instruction, of course. 5 instructions(from 1 to 5) among 6 which are on your link was okay.

    Last 6th instruction!
    I typed my WP url(www.XXXXXXXX.com/wordpress/wp-admin/install.php). Yep, ‘Step One(Typing <title> and <e-mail>)’ is okay and clicked ‘Continue Second Step’ button.

    At ‘Second Step’, browse was waiting transfortation for a while(several minutes – this must be too long, here’s a problem I think!). And nothing happen. If I check my MySQL tables, there’s no WP DBTables.

    Must be something wrong…I don’t know really~~

    It sounds like WP isn’t accessing the database you set up. Check that wp-config.php file and make sure all the details about your database are correct. Check your host’s manual and make sure that “localhost” is the correct way for your programs to access the database (it is 90% of the time, but on certain hosts it isn’t.)

    If that isn’t it, then maybe you didn’t “add user to database” when you created the database?

    I think wp-config.php file is just fine. If I make mistakes with if, WP shows me ‘DB connection error’ page. Right? Once I had before, but it’s okay now.

    I use web-hosting company and server name is ‘localhost’. Of course, the company add my account for MySQL. I can access if I type ‘mysql -u<myname> -p<passwd> <myname>’ on telnet.

    Still…I don’t know…what’s wrong?

    ps. I really appreciate your immediate replys.

    I am having the exact same problem. I have verified my database connection information in wp-config.php. The second step starts….and nothing happens in the browser. The database tables -are- created, but it seems as if the installation processes stops or fails after creating the tables, and gives no indication of failure.

    More info: WP 2.0.3….apache and MySql as specified in the instructions…Linux machine.

    Step three never happens…looked around on server for install or other logs but I don’t think there are any, and no errors on web server log, so I unfortunately can’t provide any more information πŸ™

    the same problem is happeing to me there seems to be some issue with the config file, i have experience of setting up a wordpress blog, this time for some stupid reason the installation will not go any further.

    What if you in install.php add a echo '<p>step n</p>'; after each function/block of code that is called where you increment n after each function/block. This would apply to the functions/blocks called between line 140 and 205. This way you should find out when the error occurs.

    Something could be fudge from the download. Who knows. I suggest starting fresh.

    Backup your files. Make sure you are in your html root folder. Connect via ssh if you can, and not telnet (no security with telnet).

    cp -a wordpress wordpress.bak

    Just to be on the safe side, I would recommend you redownload http://wordpress.org/latest.tar.gz to your server.

    wget ht tp://wordpress.org/latest.tar.gz

    remove the space between the t’s.

    And untar it again.

    tar -zxvf latest.tar.gz

    Then double check your wp-config.php. I suggest replacing it from wp-config-sample.php. First change to the wordpress dir.

    cd wordpress
    cp -af wp-config-sample.php wp-config.php

    Then edit your wp-config.php file. I typically use vi. Use whatever you prefer.

    vi wp-config.php

    As you know, 4 key values there.

    If the above doesn’t work. There must be some kind of connection timeout or something. Perhaps your host needs to adjust my.cnf, or php.ini, or even httpd.conf. They all have their own settings for connection timeouts. Maybe something is out of whack. I’m just speculating. Perhaps you can look up log files for mysql. Or did you?

    It might be helpful if you could provide the version numbers of mysql, php, and apache.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Installation – Second Step.’ is closed to new replies.
Skip to toolbar