Support » Plugin: Events Manager » Install problems due to old plugin version?

  • Resolved Web-Pepper

    (@pctevree)


    Hiya,

    Im currently working at this website at http://www.ride-by-the-sea.com/newsite/

    Now i try to install the Event Manager Plugin
    (https://wordpress.org/plugins/events-manager/)

    But since there is some old installation in the way i can not update to the most recent version.

    If i install the most recent version it says:

    Events Manager upgrade not complete, please upgrade to the version 4.300 or higher first from here before upgrading to this version.

    But if you do that, it tells you to install 3.0.96, and if you that it tells you to install 4.300 or higher so… im in a loop!

    Now i thought i found the solution, to get a fresh new install of the plugin.

    It sayed:

    wp_options, just delete all instances of dbem_….

    specifically dbem_version, if you’d like to keep your old settings, that’s the only real setting that affects installation

    SO…

    We deleted:

    wp_dbem_bookings
    wp_dbem_categories
    wp_dbem_events
    wp_dbem_locations
    wp_dbem_people

    I have deleted all dbem_ instances and now should be able to install the plugin.

    Too bad

    I (again) get Events Manager upgrade not complete, please upgrade to the version 4.300 or higher first from here before upgrading to this version.

    Probably there is a bug in the plugin and the update manager is unable to detect the correct version. You can try to download and install previous plugin version (i.e 4.3) then upgrade it to the latest version in order to get rid of this message.

    So… its not working! You can not add events or whatever, just see the general options.

    The options i tried:

    If i install 4.300 it says:

    Events Manager upgrade not complete, please upgrade to the version 3.0.96 or higher first from here first before upgrading to this version. We made a screencast to help you out. (That screencast should be at http://wp-events-plugin.com/blog/2011/05/09/upgrade-issues-screencast-walkthrough/ but is offline)

    If i than auto-update it says

    Events Manager upgrade not complete, please upgrade to the version 4.300 or higher first from here before upgrading to this version.

    If i delete the auto-updated version and install 3.0.96 it says:

    Plugin kan niet worden geactiveerd omdat hij een fatale fout veroorzaakt.
    (Plugin could not be activated because it causes a fatal error)
    Cannot proceed with installation, please upgrade to the version 3.0.96 from here first before upgrading to this version.

    I was able to auto-update that, but than it tells me:
    Events Manager upgrade not complete, please upgrade to the version 4.300 or higher first from here before upgrading to this version

    So i installed 3.0.97 telling me:

    Events Manager has some new features!

    Bookings can now be approved before they count towards your event’s space allocations.
    Events now have owners, and you can restrict users so they can only manage events/locations/categories they create.

    These new permissions are enabled by default, but since you upgraded it has been disabled to maintain the previous plugin behaviour. You can re-enable it from the settings page.

    It also says: Warning: call_user_func_array() expects parameter 1 to be a valid callback, function ‘wp_tiny_mce_preload_dialogs’ not found or invalid function name in /home/ridebyth/public_html/newsite/wp-includes/plugin.php on line 505

    But, after auto-update:
    Events Manager upgrade not complete, please upgrade to the version 4.300 or higher first from here before upgrading to this version.

    So.. i installed 3.0.98

    But, after auto-update:
    Events Manager upgrade not complete, please upgrade to the version 4.300 or higher first from here before upgrading to this version.

    I gave up and started trying 4.3+

    So.. i installed 4.301 and i am back to

    Events Manager upgrade not complete, please upgrade to the version 3.0.96 or higher first from here first before upgrading to this version. We made a screencast to help you out.

    So.. i installed 4.01 (wild guess)

    Plugin kan niet worden geactiveerd omdat hij een fatale fout veroorzaakt.
    (Plugin could not be activated because it causes a fatal error)
    Cannot proceed with installation, please upgrade to the version 3.0.96 or higher from here first before upgrading to this version.

    Finally, i tried 5.0.3 (first stable 5 series release)
    i got: Events Manager upgrade not complete, please upgrade to the version 4.300 or higher first from here before upgrading to this version.

    Deleted the plugin

    i’m clueless!

    Can anybody tell me what to do?

Viewing 5 replies - 1 through 5 (of 5 total)
Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Install problems due to old plugin version?’ is closed to new replies.