Support » Plugin: EntryWizard » install issue

  • Resolved robwin68

    (@robwin68)


    trying to activate get the following fatal error
    Parse error: syntax error, unexpected T_FUNCTION, expecting ‘)’ in /home/www/robertwinch.com/wordpress/wp-content/plugins/entrywizard/classes/ewz-webform.php on line 333
    please help. (i am not a coder)

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Author Josie Stauffer

    (@joanne123)

    What version of PHP are you running? EntryWizard requires at least 5.4.

    ( Many hosting companies let you set this using CPanel )

    thank you fixed it i was running 5.1 updated to 7.1

    Hi josie,
    i have test site up and running, however, my uploaded images are represented as broken images on the upload site.. they were there when i first set it up, but now they are not.
    I even tried your example webform abd layout and got the same result. what have i broken?

    Plugin Author Josie Stauffer

    (@joanne123)

    Did you do anything that could have affected your wordpress uploads folder? Or change your default thumbnail size? (The thumbnail is generated when the image is uploaded).

    Some checks you can make that may give some clues:

    Check where the broken image icon is actually looking for the thumbnail image ( how depends on your browser — try right-clicking on the icon ).

    Use ftp or cpanel to check that the images exist in the correct uploads/ewz_img_uploads folder, and that the images and the folders have full read access.

    Are the thumbnails visible via the admin Webform “Manage Items” link? Do they show a larger image when clicked?

    Are you able to upload new images?

    The broken Icon is looking in the right place but there is a ?155344398 appended immediately after the .jpg
    both the main file and the icon file are in the right place on the server
    the thumbnail does not appear in the webform manage items list with the filename

    Thanks for your quick response

    Robert

    Plugin Author Josie Stauffer

    (@joanne123)

    Try clearing your browser cache

    tried that a couple of times, and it did not change anything
    thumbnail size is 150 x150 if that helps
    I can give you admin access if you like……

    Plugin Author Josie Stauffer

    (@joanne123)

    Try grabbing the url the broken icon is looking for and putting it directly in your browser url bar.

    Try it with and without the ?155344398

    It may show an error message, or you could then check your log files.

    it appears that the uploads/ewz_img_uploads folder is
    blocked. any idea why that would be? would it be my user control plugin?”ProfileBuilder” but I would have thought that as admin I could see everything?

    Access forbidden!
    You don’t have permission to access the requested directory. There is either no index document or the directory is read-protected.

    If you think this is a server error, please contact the webmaster.

    Error 403

    Plugin Author Josie Stauffer

    (@joanne123)

    I’ve no idea what ProfileBuilder does. But did you check the folder permissions ( via ftp or cpanel) to see if it is read-protected?

    Ok I appear to have fixed it, There was a .htaccess file in the ewz_image_uploads folder.
    I have no idea where it came from a I deleted and all worked.. i will keep a lookout for it in future

    Thank you for being patient and helping out.
    Robert

    Plugin Author Josie Stauffer

    (@joanne123)

    EntryWizard should have created a .htaccess file in that folder containing one line:
    Options All -Indexes

    According to any documentation I can find, that is supposed to stop browsers from accessing the directory

      listing

    , but still allow access to named files.

    If it is blocking access to the files themselves, I’d be very interested to know why, in case others are affected.

    Please do me a favour and re-create the file with just that one line. Does it stop you from seeing the images?

    If not, the original file was probably corrupted. If it does block the images, can you tell me what sort of server/hosting you are running on?

    Jose,
    i recreated the .htaccess file and it stopped working again. renamed it and everything is OK
    I use a web hosting service called freehostia.com, have their watercircle plan, thats all i can tell you about it.

    Plugin Author Josie Stauffer

    (@joanne123)

    Thanks for trying. Since this is the first I’ve heard of such an issue, I’d guess it’s probably a plugin conflict.

    Removing the file just may create a small security risk in allowing a directory listing, but more likely whatever plugin caused the issue is taking care of it in a different way.

Viewing 14 replies - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.