Support » Plugin: Safe SVG » Insert SVG

  • Resolved stephenwp001

    (@stephenwp001)



    Hi,

    I’ve installed the plugin but cannot see any GUI. Is that correct, I assume the plugin just works?

    I uploaded an svg file and it shows in Media Lib, but it is not displayed correctly and when I try to insert the file through customiser I get an error, broken image icon, followed by this text:

    Image crop area preview. Require mouse interaction

    I can’t see the image let alone crop it. Clicking on Select does nothing.

    Any ideas?

    Thanks
    Steve

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Daryll Doyle

    (@enshrined)

    Hi @stephenwp001,

    You’re correct, there is no GUI for this plugin, once installed it just sits in the background and does its thing!

    In regards to cropping, this isn’t something that WordPress can do to SVGs itself but if you leave it with me I’ll take a look and see if there’s anything I can work out to get around it.

    Cheers,
    Daryll

    Hi Daryll,

    I’m not trying to or want to crop the image/file. Its a problem with inserting it on a page in wp?

    Thanks
    Steve

    Plugin Author Daryll Doyle

    (@enshrined)

    Hi @stephenwp001,

    That’s odd, when inserting an image into a page I don’t see any mention of cropping. Are you using a custom theme or one of the default ones and do you have any other media plugins installed that may be doing this?

    If you can show me a screenshot of what you’re seeing that’d help greatly!

    Cheers,
    Daryll

    Hi,

    By default, WP sometimes asks you if you want to crop an image before inserting it on a page. A bit concerned you don’t know that considering you’ve developed a pluging for wordpress that is image related 😉

    The text basically says: Image crop area preview. Require mouse interaction

    No worries though, the svg file is corrupt in some way.

    Thanks
    Steve

    Plugin Author Daryll Doyle

    (@enshrined)

    Hi @stephenwp001,

    As far as I’m aware it’ll ask this if you’re in the customiser but not when adding an image in the standard way, into the_content() on a page using the “Add Media” button for TinyMCE. That’s why I asked if you were using a custom theme or one of the default ones 🙂

    Glad you’ve worked out what it was anyway, if you run into any more issues then do let me know 🙂

    Cheers,
    Daryll

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Insert SVG’ is closed to new replies.