Support » Plugin: Lift: Search for WordPress » Initial Index Problem

  • Resolved fudgemonday


    First-up, thanks for developing what appears to be a great plugin for AWS Cloud Search. We’re trying to get set-up so that we can evaluate, but we’re having some issues getting our content indexed.

    1) We have a wordpress site with 40,000 posts which we would like to search over. After installing and activating the plugin the liftsearch admin page found 1,101 documents to sync; pages, posts, attachments. We synced them and can successfully search over them. However, there are ~100,000 posts, pages, attachments, so we’re missing ~99,000 which do not appear in the queue. We’ve tried manually updating a post to trigger it to get into the queue, but that had limited success – we managed to get 1 additional post in the index by doing that way, but attempts for other posts haven’t worked. Our posts go back over 10 years and we’re wondering if the publish date has any effect on what is queued to index? Also, what about the volume of posts we’re trying to index; would that be an issue? How can we force all of our posts to get into the queue to be synced?

    2) For our search we just want to search over our ‘Posts’ (related post meta, categories and tags). So we restricted the post types to just “post” as per the documentation (in our functions.php):

    add_filter('lift_indexed_post_types', function( $post_types ){
        $post_types[] = 'post';
        return $post_types;

    This doesn’t appear to have any effect on (1) the queue of documents to be synced (if we add a new ‘Page’ we still see it in the queue) (2) the front-end search still picks-up ‘Pages’ in the results. Do we have to use the ‘lift_loop();’ and/or ‘lift_search_form();’ functions in combination with the ‘lift_indexed_post_types’ filter to get the front-end search to honour the post types?

    Any insight/help would be greatly appreciated. Lift Search looks like a great way to get a good search working on WordPress and we’re hopeful this is the right solution for our needs.

    Thanks in advance for your assistance.

    – Richard

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author prettyboymp


    1) Can you check your error_logs to see if there is any error output? The sync runs via wp_cron, so a fatal error could be causing the failure.

    2) If you only want posts to be searched, the filter should return an array with only ‘post’ in it. For example:

    add_filter('lift_indexed_post_types', function( $post_types ){
        return array('post');
    Plugin Author Kevin Langley


    @fudgemonkey, I’d like to help you resolve this issue, but its just hard to do so without more information. Is there any way you can check you error logs to see if there is something that might help track down the issue?

    Hi, thanks for the replies. Unfortunately there was a deadline for the project and we tried our best to get it working, but in-the-end we had to look for another solution for search. We went with swiftype.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Initial Index Problem’ is closed to new replies.