• Resolved thomasvgeel

    (@thomasvgeel)


    Since upgrading the (free) Yoast plugin (and WordPress Core) we get an error-message on top of the pages saying:

    WordPress database error: [Unknown column ‘inclusive_language_score’ in ‘field list’]

    I never had this option enabled, but it appears that on certain pages the Yoast-plugin tries to insert a record into the “wp_yoast_indexable”-table and that this column-name reference is unknown.

    When I deactivate the plugin, the error is gone.

    Is this a known issue? How could we resolve this?

    Thanks,

    Thomas Van Geel

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 16 total)
  • Thread Starter thomasvgeel

    (@thomasvgeel)

    Dear,

    An uninstall and re-install of the plugin did not work either.

    My website is setup for the “Dutch” (Nederlands, België) language. I noticed that the “Inclusive language”-option is only available for English websites. That’s fine, but why does it throw an error on a Dutch website?

    Thanks.

    Thomas Van Geel

    Getting same error on my dev box.
    WordPress database error: [Unknown column ‘inclusive_language_score’ in ‘field list’]

    @thomasvgeel I was able to fix this by doing few things mentioned below. I am not sure about the 1st step as the tables were missing from dev environment, strange. Although I took the latest copy of database from live database but still some of the tables (SEO Yoast tables) were missing.
    1- Added missing tables in the database.
    2- Rolled backed plugin to version 20.6
    and now it is working perfectly fine.

    • This reply was modified 1 year, 1 month ago by j4jameel.
    Thread Starter thomasvgeel

    (@thomasvgeel)

    Dear,

    The rollback to version 20.6 worked for me also. Ok, fine for now then. Let’s hope they’ll fix this issue in the next update.

    Thanks for your reaction!

    Grtz, Thomas

    You are welcome.

    Getting this same error. Currently using:

    Divi
    WooCommerce
    Yoast and Yoast Premium

    It appeared when creating a new product category. Rolling back to 20.6 has removed the errors, though would prefer to see this fixed correctly.

    Hi,

    I had the same error. I rolled back to yoast 20.6 as well (I used Yoast Helper Plugin to do so).

    It seems to fix the issue but it emptied the wp_yoast_indexable table.

    Did you notice the same thing ?

    To be precise, the wp_yoast_indexable’s size decreased from 80mb -> 3mb. It still contains records for my posts, categories, terms, etc. But all records with object_type “post” and object_sub_type “attachment” are gone.

    Plugin Support Maybellyne

    (@maybellyne)

    Hello Everyone,

    I am sorry about your experience with the plugin. We are currently investigating this and will follow up with you soon.

    We’ve just released Yoast SEO 20.9. Can you please check if the problem resolves after updating to the most recent version of the plugin?

    If the problem with the unknown inclusive_language_score column still occurs after updating the plugin, resetting the indexables table via the Yoast Test Helper plugin should fix the problem by recreating the _yoast_indexable table with the correct columns.

    JamesKoussertari

    (@jameskoussertari)

    Hi, I am still getting this error. I have tried:

    • Upgrading to the latest version 20.10.
    • Rolling back to previous versions (20.9 and 20.8)
    • Deleting the page and recreating it.
    • Using the Yoast test plugin to optimise the SEO data. This just times out all the time.

    It seems to only happen on new pages that are created. Here is the error which actually appears twice, but I have included it here just once, to save space:

    WordPress database error: [Unknown column 'inclusive_language_score' in 'field list']
    INSERT INTO wp_yoast_indexable (object_type, object_id, object_sub_type, permalink, primary_focus_keyword_score, readability_score, inclusive_language_score, is_cornerstone, is_robots_noindex, is_robots_nofollow, is_robots_noimageindex, is_robots_noarchive, is_robots_nosnippet, open_graph_image, open_graph_image_id, open_graph_image_source, open_graph_image_meta, twitter_image, twitter_image_id, twitter_image_source, primary_focus_keyword, canonical, title, description, breadcrumb_title, open_graph_title, open_graph_description, twitter_title, twitter_description, estimated_reading_time_minutes, author_id, post_parent, number_of_pages, post_status, is_protected, is_public, has_public_posts, blog_id, schema_page_type, schema_article_type, object_last_modified, object_published_at, version, permalink_hash, created_at, updated_at) VALUES ('post', '29538', 'page', 'https:/domain.com/team/', NULL, '90', '0', '0', NULL, '0', NULL, NULL, NULL, 'https://domain.com/wp-content/uploads/2023/05/team.png', NULL, 'first-content-image', NULL, 'https://domain.com/wp-content/uploads/2023/05/team.png', NULL, 'first-content-image', NULL, NULL, NULL, NULL, 'Team', NULL, NULL, NULL, NULL, NULL, '40', '0', NULL, 'publish', '0', NULL, NULL, '1', NULL, NULL, '2023-06-29 08:19:20', '2023-06-28 17:26:02', '2', '50:88dde99c1330620d03f14aa9c6ca85d4', '2023-06-29 08:19:23', '2023-06-29 08:19:23')
    JamesKoussertari

    (@jameskoussertari)

    A quick update, rolling back to version 20.7 has removed the errors, but this is obviously not an ideal fix.

    It seems the problem is simply that in future versions of Yoast the inclusive_language_score database column is missing from the wp_yoast_indexable database table.

    Even when turning off the Inclusive Language option in Yoast’s Site Features setting page, it still tries to write to that column which doesn’t exist. When enabling it again it still doesn’t add the database column.

    I tried adding the column myself in phpMyAdmin but I got an error so left it alone.

    Hopefully in version 20.11, if the inclusive_language_score column doesn’t exist, it would be added automatically, which should solve the problem (I think).

    Thanks

    JamesKoussertari

    (@jameskoussertari)

    UPDATE: I tried the Yoast test plugin one more time to optimise the SEO data whilst on 20.7, and this time it completed successfully. I updated to 20.11 and now all is working well. Thanks

    solutioinc

    (@solutioinc)

    Resetting the index tables using the Yoast Helper Plugin while on 20.7, then upgrading to the latest version, seems to have removed the error messages. I’ll keep an eye on things though.

    catvetbeb

    (@catvetbeb)

    hello, I get the same error since upgrading to PHP8.0

    Do you know if this error can break the website and should I disable this plugin ?

    Thank you for your help !

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Inclusive Language option’ is closed to new replies.