Support » Localhost Installs » impossible install wordpress

  • Resolved giulianoa

    (@giulianoa)



    After updating to windows 10 local host (easyphp) didn’t run. I decided to download the new versions both of easyphp and wordpress. I installed and followed instructions but problems begin with file install in wp-admin. Answer is QUOTE:

    Warning: mysqli_real_connect(): php_network_getaddresses: getaddrinfo failed: Host sconosciuto. in C:\EasyPHP-Devserver-16.1\localweb\mioprimosito\wp-includes\wp-db.php on line 1490

    Warning: mysqli_real_connect(): (HY000/2002): php_network_getaddresses: getaddrinfo failed: Host sconosciuto. in C:\EasyPHP-Devserver-16.1\localweb\mioprimosito\wp-includes\wp-db.php on line 1490

    Deprecated: mysql_connect(): The mysql extension is deprecated and will be removed in the future: use mysqli or PDO instead in C:\EasyPHP-Devserver-16.1\localweb\mioprimosito\wp-includes\wp-db.php on line 1520

    Warning: mysql_connect(): php_network_getaddresses: getaddrinfo failed: Host sconosciuto. in C:\EasyPHP-Devserver-16.1\localweb\mioprimosito\wp-includes\wp-db.php on line 1520

    Warning: mysql_connect(): php_network_getaddresses: getaddrinfo failed: Host sconosciuto. in C:\EasyPHP-Devserver-16.1\localweb\mioprimosito\wp-includes\wp-db.php on line 1520
    UNQUOTE
    DBserver shows error log as follows QUOTE
    2016-05-25T10:42:24.834057Z 0 [Warning] TIMESTAMP with implicit DEFAULT value is deprecated. Please use –explicit_defaults_for_timestamp server option (see documentation for more details).
    2016-05-25T10:42:24.834057Z 0 [Warning] ‘NO_ZERO_DATE’, ‘NO_ZERO_IN_DATE’ and ‘ERROR_FOR_DIVISION_BY_ZERO’ sql modes should be used with strict mode. They will be merged with strict mode in a future release.
    2016-05-25T10:42:24.834057Z 0 [Warning] ‘NO_AUTO_CREATE_USER’ sql mode was not set.
    2016-05-25T10:42:24.834057Z 0 [Warning] Insecure configuration for –secure-file-priv: Current value does not restrict location of generated files. Consider setting it to a valid, non-empty path.
    2016-05-25T10:42:24.834057Z 0 [Note] ..\eds-binaries\dbserver\mysql5711x86x160524113633\bin\eds-dbserver.exe (mysqld 5.7.11) starting as process 4852 …
    UNQUOTE
    and apparently my config.php is correct; here you find the lines I modified:
    define(‘DB_NAME’, ‘mioprimosito’);
    define(‘DB_USER’, ‘admin’);
    define(‘DB_PASSWORD’, ‘admin’);
    define(‘DB_HOST’, ‘http://127.0.0.1:1111/’);
    define(‘WP_DEBUG’, true);
    and all the Keys and Salts.

    Pls help

Viewing 7 replies - 1 through 7 (of 7 total)
  • Your wp-config file is NOT correct. Change this line:

    define('DB_HOST', 'http://127.0.0.1:1111/');

    to the following:

    define('DB_HOST', '127.0.0.1:1111');

    and then see if your localhost site works.

    Thanks, done but now it only begins loading.(this is the address that opens: http://127.0.0.1:8080/edsa-mioprimosito/wp-admin/install.php) No answers and no end.
    I changed also version of wp and both 4.2.2 and 4.5.2 give the same results.

    Is this a problem of wordpress or a server crash?
    In this second situation you may indicate some forums?
    Thanks for answers.

    Do a search for “how to disable strict mode” for your local server. I ran into this once before but can’t remember where I found it to change it.

    Really I found that some MySQL blogs instruct to change the line in the file my.ini
    sql_mode=NO_ENGINE_SUBSTITUTION,STRICT_TRANS_TABLES
    with this
    sql_mode=””
    that I found well explained too in the MySQL 5.7 Reference Manual

    But no changes: PC starts loading and … I’m unable to install

    I found also a comment that told that Wp isn’t interested to resolve this problem (in windows).Sigh

    DIFFERENT note: I observed hat the hour in error log of MySQL is two hours less exactly.

    I’ll wait help or ideas some hours more, then I’ll delete this version and download the old versions hoping that the problem isn’t windows 10

    I resolved using xampp instead of easyphp. Also xampp didn’t work , but I found on the forum good and easy instructions.

    You just need to restart your database
    aqua luxury quan 4

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘impossible install wordpress’ is closed to new replies.