Support » Fixing WordPress » import-mt.php again

  • I didn’t get a reply to my last post so I’m trying again. 🙂

    – “import-mt.php” is not installed into wp-admin when one uses the installation provided by SBCYahoo hosting.
    – Can I simply get a copy of that file somehow and upload it into the correct folder in order to be able to import my MT blog files (which I have already properly exported from my MT blog)
    – Where is a safe place to get that file?

    thank you in advance!

    from WP dope and code loser and total newbie,

    Lynne Durham
    Benton Harbor, Michigan USA

Viewing 10 replies - 1 through 10 (of 10 total)
  • same issue as Lynne- I’m reading all these tutorials that tell me to use “import-mt.php” located in wp-admin, but I don’t HAVE any such file. What I can find is wp-admin/import/mt.php, but the line-by-line instructions in the “importing from MT” tutorial don’t correspond with this so I am totally confused. where do we locate the perpetually referenced “import-mt.php”?

    lynnedurham, the file I have for 2.0 is
    SBC Yahoo may not provide the import option and you may have to check with them.

    The tutorial is probably out of date.

    Citee, thank you for the reply.

    SBC refers me to the Codex which we both know is out of date. Here’s some further information…maybe you can help me?

    – WP has installed successfully.

    – The Codex directions talk of import-mt.php — a file that I do NOT have.

    Here is what I *do* have:

    **Going to this URL gives me a wonderful GUI import interface. But the only choices given are Textpattern, blogger and RSS.**

    **Going to this URL gives me a totally blank page. I’m not sure why…viewing the file in a text editor, it looks like a valid PHP file (but please remember…I am a code idiot).**

    I know how to export my MT entries. I can’t for the life of me figure out how to import into WordPress.

    why is it when I try to execute the mt.php file, I get a blank page? Any ideas of next steps for me?

    Can anyone help me? Thank you!

    Executing mt.php directly is useless, it’s a file being included by import.php.

    import-mt.php doesn’t exist in 2.0, and all references to this file seem to be related to earlier versions.

    Import documentation is not updated yet, and there’s no much use of trying to update the old way.

    In my case import _doesn’t work_ the following way:
    I choose file to upload, press “import”, and then the script freezes and never seems to end. It uploads the file to wp-content/uploads/2006/01/ folder but doesn’t do any work over it.

    WP team, we need your help 😉

    Thank you for confirming that I’m not crazy. I’m a code loser, but I’m not a total loser. 🙂

    If you hear something before I do, I hope you’ll share your findings!


    Just replying to bump this up a bit.

    Any love on this topic?



    This now offers Movable Type as an import option.

    As I said, when I execute that file (domain/blog/wp-admin/import.php) MT does NOT come up as an option.

    FyreGoddess, has there been a new release or something? Otherwise I don’t understand your post.


    I discovered how to make this work, quite by accident.

    When you export from MT, you are presented with a webpage listing all your posts in text form. Save this file as “mt.cgi”. Then, import the file “mt.cgi” from the import tab on WordPress. Worked like a charm.

    Mmm… tried the name change thing and, at least for me, ended up with the same result. No posts. No import.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘import-mt.php again’ is closed to new replies.