WordPress.org

Support

Support » Plugins and Hacks » Alfie WP Weather » [Resolved] Image toggle doesn't seem to work

[Resolved] Image toggle doesn't seem to work

  • Moderator Kathryn

    @zoonini

    Automattic Happiness Engineer

    Hi there! This is a really cool little plugin.

    I’m using it on a test site and the only toggle that doesn’t seem to be working is “image.” Whether or not I have the “image” checkbox selected in the widget, the weather graphics always show, and the display looks identical. Both with or without “image” checked off, my display looks like this:

    http://cl.ly/image/3N2c3J1f2H0t

    I also tried the shortcode version using image=0 but got the same result.

    Is there something I’m missing or is this a bug? Thanks very much for having a look!

    http://wordpress.org/extend/plugins/alfie-wp-weather/

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author appcuarium

    @appcuarium

    Hi Kathryn,

    It looks like a conditional is missing in the code, filed a bug request to the developers. Meanwhile, you could change line 12 in alfie-wp-weather.php so it looks like this:

    <div class="alfie-wp-weather-object {{daynight}}" <?php if ( $options['alfie_wp_weather_image'] ) { ?>style="background-image: url({{image_bg}}{{daynight}}.png); background-repeat: no-repeat;" <?php } ?>>

    Thanks for pointing this out.
    Best regards.
    The Alfie Team

    Moderator Kathryn

    @zoonini

    Automattic Happiness Engineer

    Thanks for the speedy attention. That did remove the large image, and left the two smaller ones below – assume that’s how it’s supposed to look?

    http://cl.ly/image/3S1w0q0C3k1a

    Plugin Author appcuarium

    @appcuarium

    Actually that’s what it does, it removes the main image without altering the text distribution. A deeper level of personalization is planned for future releases. I’ll ask the devs to include in the next version one checkbox + shortcode parameter for toggling on/off the forecast images, too.

    Best regards.
    The Alfie Team

    Moderator Kathryn

    @zoonini

    Automattic Happiness Engineer

    Thanks very much! The extra option would be handy in the future and I appreciate your quick reply. 🙂

    Plugin Author appcuarium

    @appcuarium

    Hi Kathryn,
    We just released an update including your suggestions.

    Best regards.
    The Alfie Team

    Moderator Kathryn

    @zoonini

    Automattic Happiness Engineer

    Most excellent – thanks for letting me know!

    By the way, I included your plugin in a presentation I did at this year’s WordCamp San Francisco. 🙂

    Plugin Author appcuarium

    @appcuarium

    Dear Kathryn,

    Thank you very much for your support 🙂

    Kind regards.
    The Alfie Team

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] Image toggle doesn't seem to work’ is closed to new replies.
Skip to toolbar