• Resolved micalmaster

    (@micalmaster)


    Hi in Cache Image size is more than the actual image,
    I upload a Portfolio image having size 10KB, after its in public wodrpress page size increased to 45KB almost,

    How I can disable Cache in this plugin?

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author puravida1976

    (@puravida1976)

    Hello,

    Custom uploaded files have to be cached. However, the plugin is not increasing the image size. It is likely a discrepancy of your web server or the end user browser.

    Explanation: The file saved on your local computer can be 10KB. Once saved to your server will likely be slightly different due to harddrive partition differences, operating system differences/versions, etc. It will still likely be around 9KB-12KB (you could use FTP or a control panel to verify disk used for the image). However, your web server (Apache, Nginx, etc) will send more or less data depending upon its settings, use of gzip, and other compression settings. So the size will vary. Then, the user’s browser can also cause a difference, depending upon whether it honors the compression, gzip, and other settings.

    Make sense?

    Cheers,

    Brandon

    As per your explanation there should be little difference of size between images, But I upload now an Image with size 3.3KB and after uploading its 42.41 KB,
    I don’t know where from its getting but the image URL is something like: wp-content/plugins/wp-portfolio/cache//e3341c8aded40f6f565bb14d3caac3c8_036eab42571c65137759a104a340a182.png

    I wonder why cannot the same image can be used as Portfolio why need cache? or why there is no option to disable it and used the default image uploaded, because the image I am uploading is already compressed to enough.

    Check this, how much size its showing in Cpanel,
    42.41 Size showing in Cpanel

    If image not showing above: http://tinypic.com/view.php?pic=2qu7tlj&s=9

    • This reply was modified 2 years, 10 months ago by micalmaster.
    Plugin Author puravida1976

    (@puravida1976)

    “I wonder why cannot the same image can be used as Portfolio why need cache? or why there is no option to disable it and used the default image uploaded, because the image I am uploading is already compressed to enough.”

    If you upload the image to the WordPress media library, you could use the permalink to it from there. However, uploading it through the plugin means that the image must be saved somewhere; else how could it be loaded?

    Regardless of either method, a “thumbnail” may be created. So if you are looking at the thumbnail size, then it is likely that saving the thumbnail with a hardcoded quality parameter is to blame. I did not write the original version of this plugin, so I cannot quickly say “how” it saves images.

    That said, I just remembered I had a feature added to allow upload of custom images in the original size (no modifications). In checking that, I see that the option is only available if “STW Rendering Type” is set to “Cache Locally..” Then a new option shows “Custom Thumbnail Scale Method” which can be set to “1” to avoid scaling images you upload.

    I need to ask the developer who added that feature if it can be available when “STW Rendering Type” is set to “Embedded” because I think the two options are independent of each other and this may be an oversight that it is hidden.

    However, you can try changing the option mentioned above and see how it handles the file size after making that change. Once I hear back from that dev, I will update again.

    Sincerely,

    Brandon

    I am thankful to you for replying me in full details, but unfortunately after doing the same setting as you mentioned, still the result is same, the images are still being captured from the cache folder and that’s are high in sizes.

    I am making portfolio on a page where I am considering everything is optimized, hope this issue will be resolved by your developer soon.

    Plugin Author puravida1976

    (@puravida1976)

    Hello again!

    I suspect that you did not clear your thumbnail cache after changing the setting. Based on your prior comment, it seems that the image was stored locally, so it wouldn’t be overwritten for X days (depending on your retention settings). Try clearing the thumbnail cache and then refreshing the page.

    Also, my developer helper is about to release an update to WP-Portfolio (v1.4.2.1) that will contain a couple of bug fixes, including the one related to the “Thumbnail Scaling” options being visible based on “STW Rendering Type” (which he did confirm are independent of each other so the option should always show).

    IF the image still saves larger, then it must be that the plugin runs uploaded images through a converter, even though not necessary, which will bloat the file size. This should not be the case, but if you still have the issue after clearing your cache, I will ask my dev to take a look at that code.

    Cheers,

    Brandon

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Image Cache’ is closed to new replies.