WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] http error while uploading

[Resolved] http error while uploading

  • Hi there,

    I am on the latest version of WordPress – and I cannot get past the http error. when uploading images / media in wp-admin.

    Any ideas? Here’s what I have done:

    – Cleared cache in WP and browser (chrome)
    – Checked php safemode off
    – Added correct htaccess details

    AddType x-mapp-php5 .php
    AddDefaultCharset utf-8
    
    RewriteEngine On
    RewriteRule \.shtml$ /index.php [L,R=301]
    
    php_value upload_max_filesize 20M
    php_value post_max_size 20M
    php_value max_execution_time 200
    php_value max_input_time 200
    
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_URI} !\/sitemanager
    RewriteCond %{REQUEST_URL} !uploads/bind
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    
    <IfModule mod_security.c>
    <Files async-upload.php>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </Files>
    </IfModule>
    
    <IfModule mod_env.c>
        SetEnv MODSEC_ENABLE Off
        PassEnv MODSEC_ENABLE
    </IfModule>
Viewing 2 replies - 1 through 2 (of 2 total)
  • esmi

    @esmi

    Forum Moderator

    First, do ensure that the # BEGIN WordPress ... # END WordPress block is always the very last entry in your .htaccess file. Next, have a word with your hosts to see if you can find out if mod_security really is the issue here.

    cool – this has resolved the issue. thanks!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Resolved] http error while uploading’ is closed to new replies.