Support » Plugin: PDF Thumbnails » HTTP Error

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author stianlik

    (@stianlik)

    Hi,

    I sent you an e-mail but haven’t received a response. From the phpinfo you posted it looks like ImageMagick is installed with PDF support so I don’t see any apparent reasons for why you should have problems with the plugin.

    Generating the thumbnails requires some compute power, maybe you could try to upload some smaller PDFs to see if there is an improvement?

    Same issue here. PDF file size was 5MB. Upload limit is set at 100MB.

    I’ve installed and activated the plugin – however when uploading a pdf I get ‘http error’ and/or

    Call to undefined method Imagick::setIteratorIndex() in /var/sites/xxxxxxx/public_html/wp-content/plugins/pdf-thumbnails/PdfThumbnailsPlugin.php on line 60

    My phpinfo shows ImageMagick is installed

    Plugin Author stianlik

    (@stianlik)

    SetIteratorIndex requires imagick 6.2.9 or newer, can you check the version number in phpinfo?

    Thank you for posting the actual error, makes debugging much easier 🙂

    Looks like I’m using 6.2.8!

    Will contact host and see if I can get it upgraded.

    regards

    jon

    Plugin Author stianlik

    (@stianlik)

    Haven’t heard anything in six months, marking this as resolved.

    Hi stianlik, I’m getting the same error when I activate this plugin and upload a pdf. I have imagick 6.9. My wordpress version is 4.5.3

    Can you give me a clue?

    Hi, I’m having the same problem. I’m trying to use the plugin in localhost (xampp). When I try to upload a PDF file in a post, i get the “HTTP error”. When I try to upload from the Media Library, i get the following message:

    “Fatal error: in C:\Users\Eduardo\Dropbox\xampp\htdocs\_clear\wp-content\plugins\pdf-thumbnails\PdfThumbnailsPlugin.php on line 59”.

    That’s line 59: $imagick = new Imagick($filename);

    I’ve installed GhostScript, ImageMagick and imagick

    Here’s a printscreen of my phpinfo:
    https://s32.postimg.org/nc4m4779h/phpinfo_imagick.png

    Thanks!

    Just tested with another PDF file and it worked!

    Still, that’s odd. Any ideia why it works with some files and not others?

    (Sorry for grammar mistakes, not a english speaker)

    Yup I get the same error. Here’s the whole thing

    PHP Fatal error: Uncaught exception 'ImagickException' with message 'PDFDelegateFailed[ghostscript library] -q -dQUIET -dSAFER -dBATCH -dNOPAUSE -dNOPROMPT -dMaxBitmap=500000000 -dAlignToPixels=0 -dGridFitTT=2 “-sDEVICE=pngalpha” -dTextAlphaBits=4 -dGraphicsAlphaBits=4 “-r72x72” “-sOutputFile=/tmp/magick-197485LZ1rl0r3oddl%d” “-f/tmp/magick-197485mLvAYCViAmnC” “-f/tmp/magick-197485qEA_IWTG2MqU”‘: -dname= must be followed by a valid token
    @ error/pdf.c/InvokePDFDelegate/263′ in /home/MYSITENAME/public_html/wp-content/plugins/pdf-thumbnails/PdfThumbnailsPlugin.php:59
    Stack trace:
    #0 /home/MYSITENAME/public_html/wp-content/plugins/pdf-thumbnails/PdfThumbnailsPlugin.php(59): Imagick->__construct(‘/home/MYSITENAME/…’)
    #1 /home/MYSITENAME/public_html/wp-content/plugins/pdf-thumbnails/PdfThumbnailsPlugin.php(42): PdfThumbnailsPlugin->getThumbnailBlob(‘/home/MYSITENAME/…’)
    #2 /home/MYSITENAME/public_html/wp-content/plugins/pdf-thumbnails/PdfThumbnailsPlugin.php(35): PdfThumbnailsPlugin->generateThumbnail(3202)
    #3 /home/MYSITENAME/public_ht in /home/tooltime/public_html/wp-content/plugins/pdf-thumbnails/PdfThumbnailsPlugin.php on line 59`

    Plugin Author stianlik

    (@stianlik)

    Just tested with another PDF file and it worked!
    Still, that’s odd. Any ideia why it works with some files and not others?

    It’s hard to say, most likely some of the libraries (imagemagick or ghostscript) have problems reading the file for some reason, maybe some advanced features are in use? Can you send me the PDF-file for testing?

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘HTTP Error’ is closed to new replies.