• Resolved shelleyh


    I wanted to report that I have been having several issues getting HTTP errors (ironically only with one user, not all the users) when uploading images.


    I was able to pin the issue down to this plugin since it works when deactivated. After getting the HTTP error the image would still seem to show up in the media library:


    I’ve deactivated the plugin for now and can live without it, but I wanted to at least find out if this was a known issue or not.


Viewing 15 replies - 1 through 15 (of 18 total)
  • I am getting the same exact issue above.

    However, mine is affecting all users.

    3 browsers on 2 Os’s

    WP 3.9

    Seems to be an issue today with the other end. Turned it off to get things posted in seconds. turned it back on and taking 5 – 10 mins for a 10k image!

    We also had this issue. I think there is a larger underlying issue with WordPress 3.9 here. Looks like its been on and off issue for a couple weeks when i look in our image library.

    Same issue on multiple sites.

    Nothing to do with 3.9. I’m running 3.8.2 on a few sites and over the past few weeks this plugin has been hopeless.



    WPMU DEV Support Staff

    Hi everyone,

    Thanks for reporting on all this. I’ve just been testing the smush operations on a live site and haven’t had any trouble with this.

    I wonder if maybe Yahoo just had a bit of downtime with their service?

    Could you all please try again and let us know how it works?

    Also, if you could possibly turn the debug option on at Settings > Media, then report any errors back here, that’ll help in troubleshooting it.

    If possible, could you also please try with no other plugins activated?

    And of course, if there are any other details you can think of that might be a culprit, please do let us know. Anything would help in this case as I’m not able to replicate the issue currently.



    We run multisite. One side affect of the plugin failing is the media library gets a 1px X 1px image and the media library shows grey image place holders. In addition the media uploader on the post level and the general media library freeze up. You need to close the window and come back.

    I’m also having this issue.

    When I upload a picture to ‘add media’ in new post, it takes quite a white to load or gives an HTTP error.

    As soon as I disable the plugin, the images upload immediately.


    Looks like the Yahoo APIs are down. Even accessing the Smush.it website stalls till timeout.

    @david: I’ve enabled debugging and attempted smush a previously failed image and it’s failed once again but where do I find the report?

    Same problem with HTTP when uploading images. I deactivated WP Smush it and all works.

    Also plugin can be activated but you need to set “do not process images on upload.” But it still wont work if you try to process afterwords.

    Same here HTTP error, tried everything, deactivating plugin is only thing that works



    WPMU DEV Support Staff

    Hi everyone,

    As @splitterside kindly noted, unfortunately Yahoo’s smush.it service appears to be intermittent right now as you may be able to see here:


    To avoid issues with uploads not completing currently, what you can do is turn off the auto-process feature like so:

    1. Go to Settings > Media.
    2. For the “Use Smush.it on upload?” setting, select “Do not process on upload“.

    Here’s a screenshot showing that option as well:

    @greencode thanks for checking on that, the debug details should appear on screen but I think the issue is just that Yahoo’s service itself is currently intermittent. It may be that they’re getting hit with a lot of traffic.

    I’ll run the matter by the team here to see if anything can be done. Again, thanks for reporting this everyone. We’ll see what can be done from here. 🙂


    Same issues. I disabled WP Smush.it.

    Note: I ran regenerate thumbnails on the 1×1 featured images and that fixed them. https://wordpress.org/plugins/ajax-thumbnail-rebuild/

    DITTO. long waits either produce a timeout, or 404 and http: error message. saw that it involved smush.it. deactivated plugin and images load fine now.

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘HTTP Error’ is closed to new replies.