Support » Fixing WordPress » .htaccess issues

  • ryoken

    (@ryoken)


    Like all those other people with .htaccess issues, I’ve tried putting a .htaccess in my wp subfolder but am getting a 403 error. I’ve read through all the other .htaccess threads I can find through search and tried them but i keep getting a 403. I am sure my host has mod_rewrite; however, I think, but am not sure, my host has disabled virtual directory support. any ideas?

Viewing 9 replies - 1 through 9 (of 9 total)
  • Mark (podz)

    (@podz)

    Support Maven

    To see if you have mod_rewrite:
    PHP Info
    * Paste this into a new Notepad / BBEdit file
    * <?php infophp(); ?>
    * Save as ‘info.php’
    * Upload to server. Visit in your browser (www.example.com/info.php)
    * That will give you info about your php version and mod_rewrite.
    * It’s a long page on info, so you will need to hunt it down.

    ryoken

    (@ryoken)

    Loaded Modules: mod_jk, httpd_defines, httpdmon, mod_perl, mod_php4, mod_frontpage, mod_ssl, mod_setenvif, mod_so, mod_usertrack, mod_headers, mod_expires, mod_digest, mod_auth_db, mod_auth_anon, mod_auth, mod_access, mod_rewrite, mod_alias, mod_proxy, mod_userdir, mod_actions, mod_imap, mod_asis, mod_cgi, mod_dir, mod_autoindex, mod_include, mod_info, mod_status, mod_negotiation, mod_mime, mod_log_referer, mod_log_agent, mod_log_config, mod_env, http_core
    its there.. but I noticed this too:
    Virtual Directory Support: disabled

    Mark (podz)

    (@podz)

    Support Maven

    I have that disabled too – I just checked.
    Post the htaccess here ?

    Mark (podz)

    (@podz)

    Support Maven

    Is there any reason you left out
    RewriteBase /wptest/
    and instead put it into all the lines ?
    Did it work with what wp gave you originally ?

    Mark (podz)

    (@podz)

    Support Maven

    Does the folder ‘wptest’ contain all the files and folders or did you install into different directories ?
    When it didn’t work, what errors were thrown up ?
    Do you have anything else in the .htaccess ?

    ryoken

    (@ryoken)

    ack.. bumping this. anyone have any ideas?

    Brak

    (@brak)

    Add this to the top of your generated .htaccess:
    Options +FollowSymLinks +SymLinksIfOwnerMatch
    I bet you’re using an ensim host… this problem took me weeks to sort through.

    ryoken

    (@ryoken)

    heh.. its an ensim host. and that worked. thanks so much ^_^.
    can you explain what that line means, exactly? i just wanna know outta curiosity.

    Brak

    (@brak)

    It means that it works. LOL
    To be honest, I’m not entirely sure. Something about following virtual directories.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘.htaccess issues’ is closed to new replies.