Support » Plugin: Matomo Analytics - Ethical Stats. Powerful Insights. » htaccess: AddHandler not allowed here

  • Resolved fuchsws

    (@fuchsws)


    We are not using any special Apache config, also not having issues with any other plugin.
    But accessing the admin area causes apache errors:

    /wp-content/plugins/matomo/.htaccess: AddHandler not allowed here, referer: /wp-admin/admin.php?page=matomo-summary

    Why do you need to to this, or can you have an option please to disable this?

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Thomas

    (@tsteur)

    Hi @fuchsws

    thanks for letting us know about this. Any chance you can edit your apache config?

    In case that is so, can you try to add AllowOverride All or if there’s an AllowOverride statement can you add Options so it says something like AllowOverride Options? This might fix the issue.

    Or does it generally all work when you remove “AddHandler” from this .htaccess file? Does the Matomo Reporting UI also still work (click in WP Admin dashboard on Matomo Analytics -> Reporting)? I’d then look if/how we could have an option for it.

    Thread Starter fuchsws

    (@fuchsws)

    If I remove the “AddHandler” part of your htaccess it works again.
    The Matomo Reporting UI is also affected of this and does not work.

    We restricted the AddHandler feature globally for security reasons.

    Plugin Author Thomas

    (@tsteur)

    > The Matomo Reporting UI is also affected of this and does not work.

    Thanks @fuchsws just to make sure I understand it correctly. When you remove AddHandler the Matomo Reporting UI does not work? If that’s the case, then you’d probably need to configure apache manually somehow to serve HTML files.

    > We restricted the AddHandler feature globally for security reasons.

    Do you mind letting me know how you disabled it? Maybe this way we can somehow detect it or work around it automatically

    Thread Starter fuchsws

    (@fuchsws)

    No, I need to REMOVE the AddHandler from all your htaccess files (edit the htaccess file, remove the AddHandler lines) in order to get the plugin work. It does NOT work with the default configuration. Error: “AddHandler not allowed”

    Plugin Author Thomas

    (@tsteur)

    Thanks. I wasn’t sure if you meant it’s also not working when the AddHandler is removed.

    Do you mind letting me know how this feature is disabled in your apache config? I’d like to reproduce it so I can see if I can add some If condition in the apache config depending on that configuration maybe or whether I can maybe somehow detect it automatically.

    This would be a lot easier then adding an option that changes the content of the .htaccess based on a setting.

    Thank you for your help @fuchsws

    Thread Starter fuchsws

    (@fuchsws)

    This is controlled by apache2 config:

    <Directory />
        Options -FollowSymLinks
        AllowOverride AuthConfig FileInfo Indexes Options
        Order deny,allow
        Deny from all
    </Directory>

    Overriding AddHandler is not allowed, for a good reason!

    Also this issue has been reported before: https://github.com/matomo-org/matomo/issues/11040

    I believe the “AddHandler” is not necessary at all to be changed by your plugin.

    Thanks for your help!!

    Plugin Author Thomas

    (@tsteur)

    Thanks for this. We have added a feature to disable this as part of our next major release (approx 2-3 weeks). It’s documented in https://matomo.org/faq/wordpress/how-do-i-fix-the-error-addhandler-not-allowed-here/

    Thanks for your help.

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.