WordPress.org

Forums

Jetpack by WordPress.com
How to turn off Photon? (12 posts)

  1. Edo Dijkgraaf
    Member
    Posted 2 years ago #

    I like Jetpack. Bigtime!

    On one off my websites Photon screws up the slider. It does not only give the slider different dimensions, it also puts the sharing buttons on the home although I did not ask for sharing buttons on the home.

    The theme: Yokohama (retina responsive)

    The website: http://x-pair.nl

    I disconnected so the home is back to normal again, but even without the cdn I like Jetpack.

    My question: How to turn off Photon?

    Thx!

    Edo

    http://wordpress.org/extend/plugins/jetpack/

  2. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 2 years ago #

    On one off my websites Photon screws up the slider.

    Could you give me more details about what happens when you enable Photon? Screenshots can also help, so do not hesitate to post screenshots here to describe the problem. You can use services like http://snag.gy/ to share the images.

    It also puts the sharing buttons on the home although I did not ask for sharing buttons on the home.

    If you set up your Reading Settings to use a static front page, you'll have to edit that exact page and disable the sharing buttons in the sharing module at the bottom of the post editor screen.

    How to turn off Photon?

    You can follow these instructions to deactivate any jetpack module:
    http://jetpack.me/support/#turn-off-jetpack-modules

  3. UltraMarathonEER
    Member
    Posted 1 year ago #

    I have the same issue as described above. Use a slider plugin, and with photon enabled, it causes my photos in mobile mode (aphrodite responsive theme with bxslider) to not be responsive. I makes the original image size fit in the mobile window but with a taller hieght and no responsive image.

    Hard to explain but here's a screenshot with snag.gy

    Click to get to photo

    http://freedomrunusa.com

  4. designsimply
    Member
    Plugin Contributor

    Posted 1 year ago #

    I tested http://freedomrunusa.com with iOS and it looks okay to me. Here is what I see in a test using iOS 6.1: http://i.snag.gy/0i1vb.jpg

    Your screenshot looks like it might (maybe??) be a theme/css issue and not a Photon issue to me (meaning the theme doesn't account for images displayed the way Photon displays them, but it should). I think.

    I'd like to try to reproduce the problem in a test, but I need additional info.

    What phone, OS version, and browser version are you using for mobile?

    Also, could you link to the theme and slider download page if they're public?

  5. UltraMarathonEER
    Member
    Posted 1 year ago #

    Android 4.1.1, Samsung Galaxy S3, using both the standard internet browser, and chrome on the device.

    The theme is Aphrodite http://themes.themegoods.com/?theme=Aphrodite with it's own built in slider.

    I didn't have this problem until I activated Photon. I can deactivate it, clear cache from wp supercache, and it displays properly, but when I activate photon and and clear cache again it shows as I displayed. Just odd.

  6. mmarsalli
    Member
    Posted 1 year ago #

    I have a similar problem in one of my sites. Photon resizes the photo media in my front page slider. The rest of the images look well. I had to turn it off. I would really like to get it solve because it really speeds up the site.

    Http://deportemed.com
    Thanks

  7. Richard Archambault
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    mmarsalli, could you start your own thread, please?

    Also, if you could include some screenshots to show the issue, that would help. Thanks!

  8. mmarsalli
    Member
    Posted 1 year ago #

    Ok

    Thanks

  9. designsimply
    Member
    Plugin Contributor

    Posted 1 year ago #

    @UltraMarathonEER, I don't have an Android phone, but I found a way to test Android using an emulator on browserstack.com and http://freedomrunusa.com and I could see the stretched images there: http://cl.ly/RS2q

    Can you try adding a CSS snippet like this to see if it helps?

    @media screen and (device-width: 320px) and (device-height: 640px) and (-webkit-device-pixel-ratio: 2) {
    	.flexslider,
    	#slider_wrapper {
    		height: 120px;
    	}
    }

    I got the media query part from here: http://cssmediaqueries.com/target/Samsung+Galaxy+S3.html

    Note that you might have to adjust ".flexslider .slides img" too, but try what I have above first to see if it works.

  10. UltraMarathonEER
    Member
    Posted 1 year ago #

    Thanks @designsimply. Unfortunately, that exact code is already in the css for the mobile version, although there is no mention of the .flexslider .slides img.

    I'll dig some more to try to get it fixed, but the theme author already uses your suggested code for the responsive mobile theme. Appreciate the help...I'll keep you posted.

  11. alaskatoargentina
    Member
    Posted 1 year ago #

    Hello all!

    I am also experiencing this issue, where with Photon enabled, the slider images are upscaled/resized.

    Graham

  12. Richard Archambault
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Hi alaskatoargentina,

    Could you create a new thread about your issue, and let me know your site URL so I can have a look?

    If you want your site to remain private, you can also contact us via this contact form:
    http://jetpack.me/contact-support/

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Jetpack by WordPress.com
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic