Support » Themes and Templates » how to install / reference template.php replacement

  • We’ve taken an old site (pre-3 WP) and upgraded to 3.4.2. But we are getting an error on a page:

    Warning: array_slice() expects parameter 1 to be array, null given in /home/content/k/p/w/kpw2006/html/4/wp-content/themes/calhousing/template-rss.php on line 51

    Warning: array_reverse() [function.array-reverse]: The argument should be an array in /home/content/k/p/w/kpw2006/html/4/wp-content/themes/calhousing/template-rss.php on line 52

    Warning: Invalid argument supplied for foreach() in /home/content/k/p/w/kpw2006/html/4/wp-content/themes/calhousing/template-rss.php on line 54

    I installed WP-Debug, et.al. to discover that template-rss.php has been deprecated as of WP 3 and it recommends using Simplepie.php:

    Message in WP-Debug “Use wp-includes/class-simplepie.php instead.
    Deprecated in version 3.0.”

    How do I fix WP to reference that?

Viewing 6 replies - 1 through 6 (of 6 total)
Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘how to install / reference template.php replacement’ is closed to new replies.