Support » Plugin: CommentPress Core » How to enable translation

  • Resolved riddick1771

    (@riddick1771)


    Hi,
    I could not enable translation files so that the web site becomes french.

    I put the mo/po files in languages folder, both of these folder to guarantee:
    /public_html/wp-content/languages
    /public_html/wp-content/plugins/commentpress-core/languages

    Then I edited wp-config.php
    But there is no progress
    Any help how to enable translation files?
    Thanks a lot

    Muhammed

    http://wordpress.org/plugins/commentpress-core/

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Christian Wach

    (@needle)

    Hi Muhammed,

    There are already French translation files in the languages folder in CommentPress Core. Which files did you put in there?

    Cheers, Christian

    I mean those files.
    I could not enable those translation.
    Is it enough to edit wp-config.php?
    Anything else to do?

    Plugin Author Christian Wach

    (@needle)

    I’m testing locally and can confirm that no translations are being shown when I set define('WPLANG', 'fr_FR'); in wp-config.php. I’ve confirmed that the translation file is actually being loaded, however. All very odd, particularly since some people have this working just fine – see this page for example.

    Could you email your .mo and .po files to me please? I’ll see what I can do: needle@haystack.co.uk

    Thanks, Christian

    Plugin Author Christian Wach

    (@needle)

    Okay, problem solved for me locally – the .mo file was corrupt for some reason. Have updated the plugin – let me know if it solves your issue.

    I updated the plugin and it worked.
    Now the web site is in french.
    Thanks a lot!

    I will share turkish translation files when I am done.
    Best

    Muhammed

    Plugin Author Christian Wach

    (@needle)

    It would be great to see CommentPress in Turkish, Muhammed. TIA for sharing.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘How to enable translation’ is closed to new replies.